您的位置:首页 > 其它

poj 1035 字符串处理

2017-04-19 15:32 267 查看
[align=center]Spell checker[/align]

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 25501Accepted: 9329
Description
You, as a member of a development team for a new spell checking program, are to write a module that will check the
correctness(正确性) of given words using a known dictionary of all correct words in all their forms.

If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:

?deleting of one letter from the word;

?replacing of one letter in the word with an arbitrary letter;

?inserting of one arbitrary letter into the word.

Your task is to write the program that will find all possible replacements from the dictionary for every given word.

Input
The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different.
There will be at most 10000 words in the dictionary.

The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked.

All words in the input file (words from the dictionary and words to be checked) consist only of small
alphabetic(字母的) characters and each one contains 15 characters at most.

Output
Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write
the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their
appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.
Sample Input
i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output
me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

题意:前面是字典,后面是单词表,单词表中的单词通过替换、删除、增加一个字母能否在字典中找到,如果有,则输出

#include <stdio.h>
#include <string.h>
char dic[10005][20];
char wor[55][20];
int di,dj;
int Correct(char *wor)
{
for(int i=0;i<di;i++)
if(strcmp(wor,dic[i])==0)
return 1;
return 0;
}
int Replace(char *s1,char *s2)
{
int mistake=0,i;
for(i=0;i<strlen(s1);i++)
if(s1[i]!=s2[i])
{
mistake++;
if(mistake>1)
return 0;
}
return 1;
}
int Dellet(char *s1,char *s2)
{
//mistake记录两个单词中对应位置字符不相等的个数
int mistake=0,i,j;
for(i=0,j=0;i<strlen(s1);)
{
if(s1[i]!=s2[j])
{
mistake++; i++;
if(mistake>1)
return 0;
}
else
{
i++; j++;
}
}
return 1;
}
int main()
{
di=0; dj=0;
while(gets(dic[di]) && dic[di][0]!='#')
di++;
while(gets(wor[dj]) && wor[dj][0]!='#')
dj++;
for(int i=0;i<dj;i++)//需要操作的单词
{
if(Correct(wor[i]))//原单词是否在字典中
{
printf("%s is correct\n",wor[i]); continue;
}
printf("%s: ",wor[i]);
for(int j=0;j<di;j++)//字典序列
{
int leni=strlen(wor[i]);//单词
int lenj=strlen(dic[j]);//字典
if(leni==lenj)
{//两者长度相等,则只需判断两个单词的每一位
//是否相等若只有一位不相等,则满足替换
if(Replace(wor[i],dic[j]))
printf("%s ",dic[j]);
}
else if(leni-lenj==1)
{//单词的长度比字典中的单词大 1,则判断是否能够
//通过删除一个字符得到字典中的单词
if(Dellet(wor[i],dic[j]))
printf("%s ",dic[j]);
}
else if(leni-lenj==-1)
{//单词的长度比字典中的单词小 1,则判断是否能够
//通过添加一个字符得到字典中的单词,可以通过交换
//传的参数仍然用Dellet()函数实现
if(Dellet(dic[j],wor[i]))
printf("%s ",dic[j]);
}
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: