您的位置:首页 > 其它

KMP板子题 HDU - 1686

2017-04-15 23:22 274 查看
这可能是个题目链接


Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 13125    Accepted Submission(s): 5148


Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that
counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All
the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).

One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

 

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

 

Sample Output

1
3
0

 

Source

华东区大学生程序设计邀请赛_热身赛

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1358 1711 3336 3068 2087 

 

就问有多少个匹配串。

#include<stdio.h>
#include<string.h>
int next[1000005];
char y[1000005]={0};
char x[1000005]={0};
int ans=0;
void kmp_pre(char x[],int m)
{
int i=0,j=next[0]=-1;
while(i<m)
{
while(j!=-1&&x[j]!=x[i]) j=next[j];
i++,j++;
next[i]=j;
}
}
void kmp_count(char x[],char y[],int n,int m)
{ //x是模式串,m是模式串长度,y是主串,n是主串长度
int i=0,j=0;
while(i<n)
{
while(j!=-1&&x[j]!=y[i]) j=next[j];
i++,j++;
if(j>=m)
{
ans++;
j=next[j];
}
}
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
ans=0;
scanf("%s",x);
scanf("%s",y);
int n=strlen(y);
int m=strlen(x);
kmp_pre(x,m);
kmp_count(x,y,n,m);
printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: