您的位置:首页 > 编程语言 > Java开发

java_答答租车系统(面向对象综合练习)_sdut

2017-03-31 20:07 507 查看


答答租车系统(面向对象综合练习)

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic


Problem Description

各位面向对象的小伙伴们,在学习了面向对象的核心概念——类的封装、继承、多态之后,答答租车系统开始营运了。
请你充分利用面向对象思想,为公司解决智能租车问题,根据客户选定的车型和租车天数,来计算租车费用,最大载客人数,最大载载重量。
公司现有三种车型(客车、皮卡车、货车),每种车都有名称和租金的属性;其中:客车只能载人,货车只能载货,皮卡车是客货两用车,即可以载人,也可以载货。
下面是答答租车公司的可用车型、容量及价目表:

序号     名称     载客量      载货量        租金

                           (人)     (吨)    (元/天)

  1          A            5                                 800

  2          B            5                                 400

  3          C            5                                 800

  4          D            51                             1300

  5          E            55                             1500

  6          F             5            0.45             500

  7         G             5             2.0               450

  8         H                            3                  200

  9          I                             25              1500

 10        J                             35              2000

要求:根据客户输入的所租车型的序号及天数,计算所能乘载的总人数、货物总数量及租车费用总金额。


Input

首行是一个整数:代表要不要租车 1——要租车(程序继续),0——不租车(程序结束);
第二行是一个整数,代表要租车的数量N;
接下来是N行数据,每行2个整数m和n,其中:m表示要租车的编号,n表示租用该车型的天数。


Output

若成功租车,则输出一行数据,数据间有一个空格,含义为:
载客总人数 载货总重量(保留2位小数) 租车金额(整数)
若不租车,则输出: 
0 0.00 0(含义同上)


Example Input

1
2
1 1
2 2



Example Output

15 0.00 1600


import java.text.DecimalFormat;
import java.util.Scanner;

public class Main {

public static void main(String[] args) {
Scanner in = new Scanner (System.in);
DecimalFormat x = new DecimalFormat("0.00");
Car []c = {
new Car(0,5,0,800),
new Car(1,5,0,400),
new Car(2,5,0,800),
new Car(3,51,0,1300),
new Car(4,55,0,1500),

a79b
new Car(5,5,0.45,500),
new Car(6,5,2,450),
new Car(7,0,3,200),
new Car(8,0,25,1500),
new Car(9,0,35,2000),
};
kuai:
while( in.hasNext() ){
int pd = in.nextInt();//判断
int peopleNum = 0;
double weightSum = 0;
int moneySum = 0;
if( pd==0 ){
System.out.println("0 0.00 0");
break kuai;
}
else{
int n = in.nextInt();
for( int i=0; i<n; i++ ){
int j = in.nextInt()-1;//编号
double day = in.nextDouble();//天数
moneySum += c[j].money*day;//总钱
peopleNum += c[j].passenger*day;//总人数
weightSum += c[j].weight*day;//总重量
}
}
System.out.println(peopleNum+" "+x.format(weightSum)+ " "+moneySum);
}
}
}

class Car {
public int name, money, passenger;
public double weight;
public Car( int na, int pa, double wi, int mo ){
this.name = na;
this.passenger = pa;
this.weight = wi;
this.money = mo;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: