您的位置:首页 > 其它

PAT - 甲级 - 1110. Complete Binary Tree (25) (判断完全二叉树+建树)

2017-03-29 22:04 411 查看
题目描述:

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=20) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and
gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line "YES" and the index of the last node if the tree is a complete binary tree, or "NO" and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:
9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

Sample Output 1:
YES 8

Sample Input 2:
8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

Sample Output 2:
NO 1


题目思路:

大概意思:题目给出了n个,并分别给出了n个结点的左右孩子。题目要求判断该树是否是完全二叉树。如果是,输出YES和最后一个结点的编号,否则输出NO并且输出根节点的编号。

用结构体v[i].l和v[i].r分别表示i结点的左孩子和右孩子,并且对孩子结点标记。dfs搜索所有的结点一遍,没有被标记的结点便是根节点。

找到根节点后,我们可以层次遍历整棵树,如果搜索到孩子结点为-1的情况,则比较当前位置的编号和n的关系。如果相等,则是完全二叉树,否则不是。

题目代码:

#include <cstdio>
#include <vector>
#include <iostream>
#include <queue>
using namespace std;
int n, temp, cnt, lastnode, root;
string s1, s2;
// 树
struct Tree{
int l,r;
};

int main(){
cin>>n;
vector<Tree>v(n); // 用来存放树
vector<int>m(n);

for(int i = 0; i < n; i++){
cin>>s1>>s2;
if(s1[0] != '-'){
temp = s1[0] - '0';
if(s1.length() == 2){
temp = s1[1] - '0' + temp * 10;
}
v[i].l = temp; // lc

}else{
v[i].l = -1;
}

if(s2[0] != '-'){
temp = s2[0] - '0';
if(s2.length() == 2){
temp = s2[1] - '0' + temp * 10;
}
v[i].r = temp; // rc
}else{
v[i].r = -1;
}
// m[i] i不能是负数 否则会异常退出
if(v[i].l != -1)
m[v[i].l] = 1;
if(v[i].r != -1)
m[v[i].r] = 1;
}
// 寻找根节点
for(int i = 0; i < n; i++){
if(m[i] == 0){
root = i;
break;
}
}
// 层次遍历
queue<int>q;
cnt = 0; lastnode = 0;
q.push(root);
while(!q.empty()){
int node = q.front();
if(node != -1){
cnt++;
lastnode = node;
}else{
if(cnt == n)
printf("YES %d\n",lastnode);
else
printf("NO %d\n",root);
break;
}
q.push(v[node].l);
q.push(v[node].r);
q.pop();
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: