您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表三:链表的逆置 (sdut oj)

2017-03-12 12:39 204 查看




数据结构实验之链表三:链表的逆置

Time Limit: 1000MS Memory Limit: 65536KB


Problem Description

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。




Input

输入多个整数,以-1作为结束标志。




Output

输出逆置后的单链表数据。




Example Input

12 56 4 6 55 15 33 62 -1





Example Output

62 33 15 55 6 4 56 12



Hint

不得使用数组。


Author

参考代码

#include<stdio.h>
#include<stdlib.h>

struct node
{
int data;
struct node *next;
};

int main()
{
struct node *head,*p,*tail,*q;
head = (struct node *)malloc(sizeof(struct node));
head->next = NULL;
tail = head;
int n;
while(1)
{
scanf("%d",&n);
if( n == -1 )
break;
p = (struct node *)malloc(sizeof(struct node));
p->data = n;
p->next = tail->next;
tail->next = p;
tail = p;
}
p = head->next;
q = p->next;;
head->next = NULL;
while( q != NULL )
{
p->next = head->next;
head->next = p;
p = q;
q = q->next;
}
p->next = head->next;
head->next = p;
p = head->next;
printf("%d",p->data);
p = p->next;
while(p)
{
printf(" %d",p->data);
p = p->next;
}
printf("\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息