您的位置:首页 > 理论基础 > 数据结构算法

sdutacm-数据结构实验之二叉树四:还原二叉树

2017-03-06 23:32 369 查看
数据结构实验之二叉树四:还原二叉树
TimeLimit: 1000MS Memory Limit: 65536KB

SubmitStatistic
Problem Description
给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。
Input
输入数据有多组,每组数据第一行输入1个正整数N(1
<= N <= 50)为树中结点总数,随后2行先后给出先序和中序遍历序列,均是长度为N的不包含重复英文字母(区分大小写)的字符串。
Output
 输出一个整数,即该二叉树的高度。
Example Input

9

ABDFGHIEC
FDHGIBEAC

Example Output

5

Hint
 

Author
 xam

#include<string.h>
#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#include<queue>
#include<iostream>
using namespace std;
typedef struct node
{
char data;
struct node*l;
struct node*r;
}tree;
void huifu(char *zhong,char *hou,int len)
{
if(len==0)
return ;
tree *p = new tree;
p->data = *(hou+len-1);
int i = 0;
for(;i<len;i++)
if(zhong[i]==*(hou+len-1))
{
break;
}
cout<<p->data;
huifu(zhong,hou,i);
huifu(zhong+i+1,hou+i,len-i-1);

return ;

}
tree* huifu2(char *xian,char *zhong,int len)
{
tree*head =new tree;
if(len==0)
return NULL;

head->data = *(xian);
int i = 0;
for(;i<len;i++)
{
if(zhong[i]==*xian)
break;

}
head->l = huifu2(xian+1,zhong,i);
head->r = huifu2(xian+i+1,zhong+i+1,len-i-1);
return head;

}
void last(tree*root)
{

if(root)
{

last(root->l);
last(root->r);
cout<<root->data;

}

}
int high(tree*root)
{
if(!root)
return 0;
else
return max(high(root->l),high(root->r))+1;

}
void ccout(tree*root)
{
queue<tree*>q;
tree*p =NULL;
if(root)
{
q.push(root);
}
while(!q.empty())
{
p = q.front();
q.pop();
cout<<p->data;
if(p->l)
{
q.push(p->l);
}
if(p->r)
{

q.push(p->r);
}

}

}
int main()
{

char hou[102],zhong[102],xian[102];
int o;
while(cin>>o)
{

int len;
scanf("%s%s",xian,zhong);
len = strlen(zhong);
tree* root;
root = huifu2(xian,zhong,len);
int u = high(root);
cout<<u<<endl;

}

}

/***************************************************
User name: jk160505徐红博
Result: Accepted
Take time: 0ms
Take Memory: 168KB
Submit time: 2017-02-07 15:58:38
****************************************************/


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm sdut c语言 算法