您的位置:首页 > 产品设计 > UI/UE

山东省第四届ACM大学生程序设计竞赛Rescue The Princess(一个点绕另一个点的旋转)

2017-03-04 21:31 423 查看
题目传送门:http://acm.sdut.edu.cn/onlinejudge2/index.php/Home/Index/problemdetail/pid/2603.html


Rescue The Princess

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic Discuss


Problem Description

    Several days ago, a beast caught a beautiful princess and the princess was put in prison. To rescue
the princess, a prince who wanted to marry the princess set out immediately. Yet, the beast set a maze. Only if the prince find out the maze’s exit can he save the princess.
    Now, here comes the problem. The maze is a dimensional plane. The beast is smart, and he hidden the princess
snugly. He marked two coordinates of an equilateral triangle in the maze.
The two marked coordinates are A(x1,y1)
and B(x2,y2). The third coordinate
C(x3,y3) is the maze’s exit. If the
prince can find out the exit, he can save the princess. After the prince comes into the maze, he finds out the A(x1,y1)
and B(x2,y2), but he doesn’t know
where the C(x3,y3) is. The prince
need your help. Can you calculate the C(x3,y3)
and tell him?


Input

    The first line is an integer T(1 <= T <= 100) which is the number of test cases. T test cases follow.
Each test case contains two coordinates A(x1,y1)
and B(x2,y2), described by four floating-point
numbers x1, y1, x2,
y2 ( |x1|, |y1|,
|x2|, |y2| <=
1000.0).
    Please notice that A(x1,y1)
and B(x2,y2) and C(x3,y3)
are in an anticlockwise direction from the equilateral triangle. And coordinates A(x1,y1)
and B(x2,y2) are given by anticlockwise.


Output

    For each test case, you should output the coordinate of C(x3,y3),
the result should be rounded to 2 decimal places in a line.


Example Input

4
-100.00 0.00 0.00 0.00
0.00 0.00 0.00 100.00
0.00 0.00 100.00 100.00
1.00 0.00 1.866 0.50



Example Output

(-50.00,86.60)
(-86.60,50.00)
(-36.60,136.60)
(1.00,1.00)



Hint

 


Author

2013年山东省第四届ACM大学生程序设计竞赛

题意:已知一个等边三角形的两个顶点A(x1,y1)和B(x2,y2),求第三个顶点,按照逆时针顺序求。

A(x1,y1)           B(x2,y2)

设x=x2-x1,y=y2-y1,B绕A点旋转a度之后到C,则C的坐标为:

C( x*cos(a)-y*sin(a)+x1 , y*cos(a)+x*sin(a)+y1)。
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
int T;
double x1, y1, x2, y2, x, y, c1, c2;
cin >> T;
while(T--)
{
cin >> x1 >> y1 >> x2 >> y2;
x = x2 - x1;
y = y2 - y1;
c1 = x/2 - y*sqrt(3)/2 + x1;
c2 = y/2 + x*sqrt(3)/2 + y1;
printf("(%.2f,%.2f)\n", c1, c2);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐