您的位置:首页 > 其它

POJ1056_IMMEDIATE DECDABILITY_二叉树搜索||字典树

2017-02-27 21:05 176 查看
IMMEDIATE DECODABILITY

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13392 Accepted: 6415
Description

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that
each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight. 

Examples: Assume an alphabet that has symbols {A, B, C, D} 

The following code is immediately decodable: 

A:01 B:10 C:0010 D:0000 

but this one is not: 

A:01 B:10 C:010 D:0000 (Note that A is a prefix of C) 

Input

Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing
a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
Sample Input
01
10
0010
0000
9
01
10
010
0000
9

Sample Output
Set 1 is immediately decodable
Set 2 is not immediately decodable


大致题意:

<
4000
span style="white-space:pre;">给出n段只含有0和1的序列,请你判断在所有给出的序列中,是否存在一个数列是另一个序列的前缀。

大体思路:

按道理说这道题是个典型的字典树,但是由于符号只有0和1,所以二叉数完全可以解决。

#include<cstdio>
#include<cstring>

bool s [2000];
char str [15];
bool flag;

int main ()
{
//freopen("in.txt","r",stdin);

int cas=0;
while(gets(str)){
if(*str=='9'){
if(flag) printf("Set %d is immediately decodable\n",++cas);
else printf("Set %d is not immediately decodable\n",++cas);
flag=1;
memset(s,0,sizeof(0));
continue;
}

flag=1;
if(flag){
int len=strlen(str);

int i=0,j=1;
for(;i<len;i++){
j=j*2+str[i]-'0';
if(s[j]) break;
}

if(i>=len) s[j]=1;
else flag=0;
}

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: