您的位置:首页 > 其它

HDU3360-二分图最小点覆盖

2017-02-16 12:34 351 查看


National Treasures

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1295    Accepted Submission(s): 469


Problem Description

The great hall of the national museum has been robbed few times recently. Everyone is now worried about the security of the treasures on display. To help secure the hall, the museum contracted with a private security company to provide additional guards to
stay in the great hall and keep an eye on the ancient artifacts. The museum would like to hire the minimum number of additional guards so that the great hall is secured.

The great hall is represented as a two dimensional grid of R × C cells. Some cells are already occupied with the museum’s guards. All remaining cells are occupied by artifacts of different types (statues, sculptures, . . . etc.) which can be replaced by new
hired guards. For each artifact, few other cells in the hall are identified as critical points of the artifact depending on the artifact value, type of vault it is kept inside, and few other factors. In other words, if this artifact is going to stay in the
hall then all of its critical points must have guards standing on them. A guard standing in a critical position of multiple artifacts can keep an eye on them all. A guard, however,

can not stand in a cell which contains an artifact (instead, you may remove the artifact to allow the guard to stay there). Also you can not remove an artifact and leave the space free (you can only replace an artifact with a new hired guard).

Surveying all the artifacts in the great hall you figured out that the critical points of any artifact (marked by a 

 ) are always a subset of the 12 neighboring
cells as shown in the grid below.



Accordingly, the type of an artifact can be specified as a non-negative integer where the i-th bit is 1 only if critical point number i from the picture above is a critical point of that artifact. For example an artifact of type 595 (in binary 1001010011) can
be pictured as shown in the figure below. Note that bits are numbered from right to left (the right-most bit is bit number 1.) If a critical point of an artifact lies outside the hall grid then it is considered secure.



You are given the layout of the great hall and are asked to find the minimum number of additional guards to hire such that all remaining artifacts are secured.

 

Input

Your program will be tested on one or more test cases. Each test
f787
case is specified using R+1 lines.

The first line specifies two integers (1<= R,C <= 50) which are the dimensions of the museum hall. The next R lines contain C integers separated by one or more spaces. The j-th integer of the i-th row is -1 if cell (i, j) already contains one of the museum’s
guards, otherwise it contains an integer (0 <= T <= 212) representing the type of the artifact in that cell.

The last line of the input file has two zeros.

 

Output

For each test case, print the following line:

k. G

Where k is the test case number (starting at one,) and G is the minimum number of additional guards to hire such that all remaining artifacts are secured.

 

Sample Input

1 3
512 -1 2048
2 3
512 2560 2048
512 2560 2048
0 0

 

Sample Output

1. 0
2. 2

Hint
The picture below shows the solution of the second test case where the two artifacts in the middle are replaced by guards.



题目大意:

                 给你一个n*m的矩阵,在该矩阵中放置一些警卫,每个警卫所能守卫的格子为他的二进制中1的位置如上图,编号1到12分别表示第i位为1所能守卫的格子,矩阵中除了警卫和值为-1外都是文物然后问你最少放多少个警卫才能守住所有的文物

题目思路:

               首先我们考虑怎么建图,我知道每个警卫所能守卫的格子,我们不妨先将二维坐标转换成一维坐标,然后每个守卫与他所能守卫的格子连边,这样我们就转换成了求最少的点使得所有的边的至少一个端点被选中,即最小点覆盖模型,所以我们只需进行最大匹配就行

AC代码:

#include<cstring>
#include<cstdio>
#include<vector>
const int maxn = 55;
using std::vector;

int mp[maxn][maxn],link[maxn*maxn];
bool vis[maxn*maxn];
vector<int>v[maxn*maxn];
int n,m;

int fx[14][2]={-1,-2,-2,-1,-2,1,-1,2,1,2,2,1,2,-1,1,-2,-1,0,0,1,1,0,0,-1}; //记录12个方向

bool dfs(int u){
for(int i=0;i<v[u].size();i++){
int vv = v[u][i];
if(!vis[vv]){
vis[vv]=true;
if(link[vv]==-1||dfs(link[vv])){
link[vv]=u;
return true;
}
}
}
return false;
}

int main()
{
int T=1;
while(scanf("%d%d",&n,&m),n+m){
memset(v,0,sizeof(v));
memset(link,-1,sizeof(link));
for(int i=1;i<=n;i++)for(int j=1;j<=m;j++)scanf("%d",&mp[i][j]);
for(int i=1;i<=n;i++)
for(int j=1;j<=m;j++)
if(mp[i][j]!=-1)
for(int k=0;k<12;k++) //枚举12个方向
if((mp[i][j]>>k)&1){ //状态位为1
int h = i+fx[k][0],l=j+fx[k][1];
if(h>=1&&h<=n&&l>=1&&l<=m&&mp[h][l]!=-1){
int x = (i-1)*m+j,y=(h-1)*m+l;
v[x].push_back(y);
v[y].push_back(x);
}
}
int ans = 0;
for(int i=1;i<=n*m;i++){
memset(vis,false,sizeof(vis));
if(dfs(i))ans++;
}
printf("%d. %d\n",T++,ans/2);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: