您的位置:首页 > 其它

寒假训练——POJ - 3009 Curling 2.0 dfs and similiar

2017-01-18 19:55 260 查看
On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game
is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed
until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.



Fig. 1: Example of board (S: start, G: goal)
The movement of the stone obeys the following rules:

At the beginning, the stone stands still at the start square.
The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
Once thrown, the stone keeps moving to the same direction until one of the following occurs:
The stone hits a block (Fig. 2(b), (c)).
The stone stops at the square next to the block it hit.
The block disappears.

The stone gets out of the board.
The game ends in failure.

The stone reaches the goal square.
The stone stops there and the game ends in success.

You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.



Fig. 2: Stone movements
Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).



Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board 

First row of the board 

... 
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position
The dataset for Fig. D-1 is as follows:

6 6 

1 0 0 2 1 0 

1 1 0 0 0 0 

0 0 0 0 0 3 

0 0 0 0 0 0 

1 0 0 0 0 1 

0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input
2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0


Sample Output
1
4
-1
4
10
-1


其实这个问题可以化简为一个DFS问题,不用vis数组进行回溯,但需要对消失的阻挡块进行回溯。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <climits>
#include <cstring>
#include <string>
#include <set>
#include <map>
#include <queue>
#include <stack>
#include <vector>
#include <list>
#define rep(i,m,n) for(i=m;i<=n;i++)
#define rsp(it,s) for(set<int>::iterator it=s.begin();it!=s.end();it++)
const int inf_int = 2e9;
const long long inf_ll = 2e18;
#define inf_add 0x3f3f3f3f
#define mod 1000000007
#define vi vector<int>
#define pb push_back
//#define mp make_pair
#define fi first
#define se second
#define pi acos(-1.0)
#define pii pair<int,int>
#define Lson L, mid, rt<<1
#define Rson mid+1, R, rt<<1|1
const int maxn=5e2+10;
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
inline int read(){int ra,fh;char rx;rx=getchar(),ra=0,fh=1;
while((rx<'0'||rx>'9')&&rx!='-')rx=getchar();if(rx=='-')
fh=-1,rx=getchar();while(rx>='0'&&rx<='9')ra*=10,ra+=rx-48,
rx=getchar();return ra*fh;}
//#pragma comment(linker, "/STACK:102400000,102400000")
ll gcd(ll p,ll q){return q==0?p:gcd(q,p%q);}
ll qpow(ll p,ll q){ll f=1;while(q){if(q&1)f=f*p;p=p*p;q>>=1;}return f;}
int dir[8][2] ={{1,0},{-1,0},{0,1},{0,-1},{1,1},{-1,1},{1,-1},{-1,-1}};
void dfs(int x,int y,int step);

ll re=0;
int mpp[25][25];
int book[25][25];
int n,m;
int stx,sty;
int enx,eny;
int main()
{
int t;
ios::sync_with_stdio(false);
while(cin >>m>>n)
{
if(m==0&&n==0)
break;
memset(mpp,0,sizeof(mpp));
memset(book,0,sizeof(book));
for(int i=1;i<=n;i++)
{
for(int j=1;j<=m;j++)
{
cin >> t;
if(t==2)
{
stx = i;
sty = j;
}
else if(t==3)
{
enx = i;
eny = j;
}
else
{
mpp[i][j] = t;
}
}
}
re = inf_int;
dfs(stx,sty,1);

if(re<=10)
cout << re<<endl;
else
cout <<-1<<endl;
}

}

void dfs(int x,int y,int step)
{

if(step>11)
return ;

int flag = 0;
int xx,yy;
xx = x;
yy = y;
while(mpp[xx-1][yy]==0)
{
xx--;
if(xx==enx&&yy==eny)
{
if(re>step)
{
re = step;
}
flag =1;
break;
}
if(xx==0)
break;
}
if(xx!=0&&flag == 0&&xx!=x)
{
//cout << "up"<<endl;
// book[xx][yy]=1;
mpp[xx-1][yy]=0;
dfs(xx,yy,step+1);
mpp[xx-1][yy]=1;
// book[xx][yy]=0;
}

flag = 0;
xx = x;
yy = y;
while(mpp[xx][yy-1]==0)
{
if(yy==0)
break;
yy--;
if(xx==enx&&yy==eny)
{
if(re>step)
{
re = step;
}
flag =1;
break;
}
}

if(yy!=0&&flag == 0&&yy!=y)
{
//cout << "left"<<endl;
//book[xx][yy]=1;
mpp[xx][yy-1]=0;
dfs(xx,yy,step+1);
mpp[xx][yy-1]=1;
//book[xx][yy]=0;
}

flag = 0;
xx = x;
yy = y;
// cout<<xx<<n<<"!@@@@@@@@@@@"<<endl;
while(mpp[xx+1][yy]==0)
{
xx++;

if(xx==enx&&yy==eny)
{
if(re>step)
{
re = step;
}
flag =1;
// cout<<"down@@"<<step<<endl;
break;
}
if(xx==n+1)
break;
}
if(xx!=n+1&&flag == 0&&xx!=x)
{
//cout << "down"<<endl;
//book[xx][yy]=1;
mpp[xx+1][yy]=0;
dfs(xx,yy,step+1);
mpp[xx+1][yy]=1;
// book[xx][yy]=0;
}

flag = 0;
xx = x;
yy = y;
while(mpp[xx][yy+1]==0)
{
yy++;
if(xx==enx&&yy==eny)
{
if(re>step)
{
re = step;
}
flag =1;
// cout<<"right@@"<<step<<endl;
break;
}
if(yy==m+1)
break;
}
if(yy!=m+1&&flag == 0&&yy!=y)
{
//book[xx][yy]=1;
mpp[xx][yy+1]=0;
dfs(xx,yy,step+1);
mpp[xx][yy+1]=1;
// book[xx][yy]=0;
}
//cout <<x<<" "<<y<<" "<<re<<endl;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: