您的位置:首页 > 其它

hdu FatMouse's Speed(DP)(打印路径)

2017-01-12 11:06 260 查看
 FatMouse's Speed

Problem Description

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

 

Input

Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information
for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed. 

 

Output

Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m
then it must
be the case that 

W[m[1]] < W[m[2]] < ... < W[m
]

and 

S[m[1]] > S[m[2]] > ... > S[m
]

In order for the answer to be correct, n should be as large as possible.

All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 

 

Sample Input

6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

 

Sample Output

4
4
5
9
7

思路:类似于单调递增最长子序列
代码:
#include<stdio.h>
#include<algorithm>
using namespace std;
struct node//记录原始下标
{
int x,y;
int st;
} q[1010];
bool cmp(node a,node b)
{
if(a.x==b.x)
return a.y>b.y;
return a.x<b.x;
}
struct zxc//记录路径
{
int st,front;
} a[1010];
int flag=0;
void print(int i)//打印路径
{
if(a[i].front)
print(a[i].front);
else
{
flag=1;
printf("%d\n",a[i].st);
return ;
}
if(flag)
{
printf("%d\n",a[i].st);
return ;
}
}
int dp[1010];
int main()
{
int x,y,ps=1,i,j;
while(~scanf("%d%d",&x,&y))//输入数据
q[ps].x=x,q[ps].y=y,q[ps].st=ps,ps++;
sort(q+1,q+ps,cmp);
for(i=0; i<ps; i++)//初始化
dp[i]=1,a[i].st=q[i].st;
for(i=2; i<ps; i++)
for(j=i-1; j>=0; j--)
if(q[i].y<q[j].y&&q[i].x>q[j].x&&dp[i]<dp[j]+1)
{
dp[i]=dp[j]+1;
a[i].st=q[i].st;
a[i].front=j;
}
int maxn=0,k;
for(i=0; i<ps; i++)//寻找最长的序列
if(maxn<dp[i])
maxn=dp[i],k=i;
printf("%d\n",maxn);
print(a[k].front);
printf("%d\n",a[k].st);//输出最后一个
return 0;
}


下面的做了下修改,用循环存储路径再打印出来
代码:
#include<stdio.h>
#include<algorithm>
using namespace std;
struct node
{
int x,y;
int st;
} q[1010];
bool cmp(node a,node b)
{
if(a.x==b.x)
return a.y>b.y;
return a.x<b.x;
}
struct zxc
{
int st,front;
} a[1010];
int dp[1010],b[1010];
int main()
{
int x,y,ps=1,i,j;
while(~scanf("%d%d",&x,&y))
q[ps].x=x,q[ps].y=y,q[ps].st=ps,ps++;
sort(q+1,q+ps,cmp);
for(i=0; i<ps; i++)
dp[i]=1,a[i].st=q[i].st;
for(i=2; i<ps; i++)
for(j=i-1; j>=0; j--)
if(q[i].y<q[j].y&&q[i].x>q[j].x&&dp[i]<dp[j]+1)
{
dp[i]=dp[j]+1;
a[i].st=q[i].st;
a[i].front=j;
}
int maxn=0,k;
for(i=0; i<ps; i++)
if(maxn<dp[i])
maxn=dp[i],k=i;
printf("%d\n",maxn);
int s=maxn;
while(s)//存储路径
{
b[s]=a[k].st;
k=a[k].front;
s--;
}
for(i=1;i<=maxn;i++)
printf("%d\n",b[i]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: