您的位置:首页 > 其它

poj --1125----Stockbroker Grapevine(多源最短路径)

2016-12-29 10:45 337 查看
Stockbroker Grapevine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 34975 Accepted: 19417
Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours
in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker
to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community.
This duration is measured as the time needed for the last person to receive the information.
Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people
are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number
referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number
of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer
minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass
the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.
Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0
Sample Output

3 2
3 10
Source

Southern African 2001

题意:股票经纪人都愿意相信谣言,每个股票经纪人都只会相信熟人说的话,传谣言需要时间,告诉这些股票经纪人中的一个人一条谣言,他就会把这条谣言传出去,如何选择这个人,使得其他的每个人都会知道,而且最后那个人知道的时间会最早。
输入输出:题目数据的输入第一行为n,代表总人数,当n=0时结束程序,接着n行,第i+1行的第一个是一个整数t,表示第i个人与t个人的关系要好,接着有t对整数,每对的第一个数是j,表示i与j要好,第二个数是从i直接传递谣言到j所用的时间,数据的输出是两个整数,第一个为选点的散布谣言的起点,第二个整数时所有人得知谣言的最短时间。例如,对于数据1,可知如果从3开始传播,则1,2得知谣言的时间都是2,所用的时间比从1,2开始传播所用的时间要短,故程序的输出时3
2;







思路:题目中隐含了一个条件是一个人可以将谣言传给多个人,比如说,B,C,D都相信A说的话,但是相信的时间按不同,所以,A同时将谣言传给B,C,D,3人可能不是同时相信,但是最后一个人相信的时间就是A将谣言传递给这3个人的总时间。 典型的最短路问题,由于最开始选择的出发点不固定,因此需要求出所有点之间的最短路。采用floyd算法。判断图是否连通,可以通过判断是否从图中所有的点出发都存在无法到达的点来实现:若从图中所有的点出发,都存在无法到达的点,则说明图不连通。

#include<stdio.h>
#include<string.h>
#define MAX 0x3fffffff
int map[101][101];
int main()
{
int n,i,j,t,m,max,min;
while(scanf("%d",&n),n)
{
for(i=1;i<=n;++i)
{
map[i][i]=0;
for(j=1;j<i;++j)
map[i][j]=map[j][i]=MAX;
}
for(i=1;i<=n;++i)
{
scanf("%d",&m);
while(m--)
{
scanf("%d%d",&j,&t);
map[i][j]=t;
}
}
for(i=1;i<=n;++i)
for(j=1;j<=n;++j)
for(t=1;t<=n;++t)
if(map[j][t]>map[j][i]+map[i][t])
map[j][t]=map[j][i]+map[i][t];
min=MAX;
for(i=1;i<=n;++i)
{
max=0;
for(j=1;j<=n;++j)
{
if(j==i)
continue;
if(map[i][j]>max)
max=map[i][j];
}
if(max<min)
{
min=max;
t=i;
}
}
if(min==MAX)
printf("disjoint\n");
else
printf("%d %d\n",t,min);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: