您的位置:首页 > 其它

POJ-1703并查集应用

2016-12-08 10:05 218 查看
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to.
The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]

where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message
as described above.
Output
For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output
Not sure yet.
In different gangs.
In the same gang.

分析:并查集+路径压缩,开一个数组存放自己的朋友,一个存放自己的敌人
问题:找给你一些关系看他们是敌人还是朋友

#include<cstdio>
#include<cstring>

using namespace std;
int fri[100005];
int notfri[100005];
int n,m;
int _find(int a){ //找是不是朋友
int r=a;
while(fri[r]!=r){
r=fri[r];
}
int i=a,j;
while(i!=r){
j=fri[i]; //保存此变量的根节点
fri[i]=r; //把父节点改为根节点
i=j; //下一个
}
return fri[r];
}

void join(int a,int b){ //这两个人是朋友
int rx=_find(a);
int ry=_find(b);
if(rx!=ry){
fri[rx]=ry;
}
}
void answer(int a,int b){
if(_find(a)==_find(b)) printf("In the same gang.\n");
else if(_find(a)==_find(notfri[b])) printf("In different gangs.\n");
else printf("Not sure
9daf
yet.\n");
}
void different(int a,int b){ //这两人互为敌人...敌人的敌人是朋友
if(notfri[a]) join(notfri[a],b);
if(notfri[b]) join(notfri[b],a);
notfri[a]=b;
notfri[b]=a;
}

int main(){
int q;
// freopen("2.txt","r",stdin);
scanf("%d",&q);
while(q--){
int a,b;
memset(notfri,0,sizeof(notfri));
scanf("%d%d",&n,&m);
for(int i=1;i<=n;i++) fri[i]=i;
char t;
while(m--){
getchar();
scanf("%c%d%d",&t,&a,&b);
if(t=='A'){
answer(a,b);
}
else if(t=='D'){
different(a,b);
}
}
}
return 0;
}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: