您的位置:首页 > Web前端 > Node.js

pat甲1115. Counting Nodes in a BST(BST二叉搜索树)

2016-12-06 21:37 375 查看


1115. Counting Nodes in a BST (30)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than or equal to the node's key.

The right subtree of a node contains only nodes with keys greater than the node's key.

Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000) which is the size of the input sequence. Then given in the next line are the N integers in [-1000 1000] which are supposed to be inserted into an initially
empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.
Sample Input:
9
25 30 42 16 20 20 35 -5 28

Sample Output:
2 + 4 = 6

tips:数组模拟建树;搜索统计每层结点的个数;

因为有重复的数字以及正负数采用下标来唯一记录每一个下表对应数字的左右儿子


#include<iostream>
using namespace std;
int t[1030][2];
int a[1030];
int n,rt,maxn;
int ans[1030];
void insert(int &x,int y,int depth)
{
maxn=max(maxn,depth);
if(!x){x=y;	ans[depth]++;return;}
if(a[y]<=a[x])insert(t[x][0],y,depth+1);
else insert(t[x][1],y,depth+1);
}
int main()
{
cin>>n;
for(int i=1;i<=n;i++)cin>>a[i],insert(rt,i,1);
cout<<ans[maxn]<<" + "<<ans[maxn-1]<<" = "<<ans[maxn]+ans[maxn-1]<<endl;
return 0;
}



#include<iostream>
#include<cstring>

using namespace std;

int a[1001];
int root,maxn;//根节点坐标,最大深度
int t[1001][2];//模拟建树
int ans[1001];//统计每一层的结点个数;
void insert(int &x,int y){

//到达要插入的位置
if(!x){
x=y;
return;
}
if(a[y]<=a[x])insert(t[x][0],y);
else insert(t[x][1],y);
}
//从根节点开始搜索,逐层搜索
void dfs(int index,int dep){
ans[dep]++;
maxn=max(maxn,dep);

if(t[index][0])dfs(t[index][0],dep+1);
if(t[index][1]) dfs(t[index][1],dep+1);
}
int main(){

int n;cin>>n;
for(int i=1;i<=n;i++){
cin>>a[i];
insert(root,i);
}
dfs(1,1);
//for(int i=maxn;i>=1;i--)cout<<ans[i]<<" ";
cout<<ans[maxn]<<" + "<<ans[maxn-1]<<" = "<<ans[maxn]+ans[maxn-1]<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: