您的位置:首页 > 其它

PAT 1089 (排序||归并,直接插入)

2016-12-06 17:16 120 查看
According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts
it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1
sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed
that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed
that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:
10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:
Merge Sort
1 2 3 8 4 5 7 9 0 6


判断是归并还是插入,暴力判断即可。

原数组a,归并排序后数组b..

难点:找到当前归并排序的长度,这些处理起来会炒鸡麻烦,我们可以用枚举判定答案法,,,,哎 自己果然还是太弱

可以从2开始暴力枚举判断,直到a完全等b。。。。

提供了一种新的解题思路 mark!!!!!!!!

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int N = 111;
int a
,b
;
int main()
{
ios::sync_with_stdio(false);
int n,i,j,p,flag,k,f;
cin>>n;
for(i=0;i<n;i++) cin>>a[i];
for(i=0;i<n;i++) cin>>b[i];
for(i=1;i<n;i++) {
if(b[i]<b[i-1]) break;
}
p=i;
for(j=i;j<n;j++) if(a[j]!=b[j]) break;
f=1;
if(j!=n) {
flag=1;
cout<<"Merge Sort"<<endl;
while(flag) {
if(f) k=2,f=0;
else k=k*2;
flag=0;
for(i=0;i<n;i++) if(a[i]!=b[i]) flag=1;
for(i=0;i<n;i+=k) sort(a+i,a+min(n,i+k));
}
for(i=0;i<n;i+=k) sort(b+i,b+min(n,i+k));
}
else {
cout<<"Insertion Sort"<<endl;
sort(b,b+min(p+1,n));
}
for(i=0;i<n;i++) {
if(i) cout<<" ";
cout<<b[i];
}
cout<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: