您的位置:首页 > 其它

POJ 1797 Heavy Transportation dijkstra 变形

2016-12-04 00:24 507 查看
C - Heavy TransportationTime Limit:3000MS     Memory Limit:30000KB     64bit IO Format:%lld& %lluSubmit StatusDescriptionBackground Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is neededon which all streets can carry the weight. Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. Problem You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer'splace). You may assume that there is at least one path. All streets can be travelled in both directions.InputThe first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines containtriples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.OutputThe output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo cantransport to the customer. Terminate the output for the scenario with a blank line.Sample Input
1
3 3
1 2 3
1 3 4
2 3 5
Sample Output
Scenario #1:
4
和poj 2253 差不多 要好好理解
题意:要从城市1到城市N运送货物,有M条道路,每条道路都有它的最大载重量,问从城市1到城市N运送最多的重量是多少。其实题意很简单,就是找一条1-->N的路径,在不超过每条路径的最大载重量的情况下,使得运送的货物最多。一条路径上的最大载重量为这个路径上权值最小的边;思路:dijkstra 的变形,我们只需要每次选取离源点载货量最多的那条边,然后通过它去松弛所有路径上的最大载重量;说一下为什么要每次选取离源点权值最大的那个点去松弛,我们知道原始的dijkstra是每次选取离源点最近的边去松弛使得求出的源点到其余点的单源最短路径最短,那么我们这里希望让它路径上权值最小的边尽可能的大,我们就需要去选取离源点权值最大的点,使得它的该路径的最大载重量大一些;
#include<stdio.h>
#include<iostream>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int inf=0x3f3f3f3f;
int dis[1111];
int mp[1111][1111];
bool book[1111];
int n,m;
void dijkstra(int start)
{
int ans;
memset(book,0,sizeof(book));
for(int i=1;i<=n;i++)
dis[i]=mp[1][i];
for(int i=1;i<=n;i++)
{
ans=0;
int v;
for(int j=1;j<=n;j++)
{   if(!book[j]&&dis[j]>ans)//这里需要每次选取离源点权值最大的边去松弛;使得最大载重量尽可能的大;
{  ans=dis[j];
v=j;
}
}
book[v]=1;
for(int j=1;j<=n;j++)
{
dis[j]=max(dis[j],min(dis[v],mp[v][j]));//又是比较绕的地方,这里是要选取每条路径中最小的权值作为该路径的最大载重量,我们又要找路径中最大载重量最大是多少,所以此时dis数组中保存的为源点到该点的最大载重量
}
}
return ;
}
int main()
{   int k,a,b,c;
int t=1;
scanf("%d",&k);
while(k--){
scanf("%d%d",&n,&m);
memset(mp,0,sizeof(mp));
for(int i=1;i<=m;i++)
{  scanf("%d %d %d",&a,&b,&c);
if(c>0)
mp[a][b]=mp[b][a]=c;
}
dijkstra(1);
printf("Scenario #%d:\n%d\n\n", t++, dis[n]);
}
}

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm 图论