您的位置:首页 > 编程语言 > C语言/C++

HDU 1029(鸽巢原理)

2016-12-04 00:05 246 查看


Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)

Total Submission(s): 28525    Accepted Submission(s): 12081


Problem Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?

 

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is
terminated by the end of file.

 

Output

For each test case, you have to output only one line which contains the special number you have found.

 

Sample Input

5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1

 

Sample Output

3
5
1解析详见代码:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<queue>
#include<iostream>
#include<algorithm>
using namespace std;

int main()
{
//利用鸽巢原理
int n;
int a,c,x;
while(~scanf("%d",&n))
{
c=0;
while(n--)
{
scanf("%d",&a);
if(c==0)//每次是零就更新
{
x=a;
c++;
}

else if(a==x) //再次遇到这个数就++
{
c++;
}
else //如果不是这个数就--
{
c--;
}
}
printf("%d\n",x);//因为是(N+1)/2个,所以最后肯定会省一个
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息