您的位置:首页 > Web前端 > Node.js

Counting Nodes in a BST

2016-12-03 20:27 260 查看
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than or equal to the node's key.

The right subtree of a node contains only nodes with keys greater than the node's key.

Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000) which is the size of the input sequence. Then given in the next line are the N integers in [-1000 1000] which are supposed to be inserted into an initially
empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.
Sample Input:
9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6

建一个带深度的二叉搜索树就行了
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <vector>
using namespace std;

typedef struct Node *Tree;
struct Node {
int  Element;
int  depth;
Tree  Left;
Tree  Right;
};

static int count;
int max1=0;
int qq[2];
Tree Insert(int x, Tree T)
{
if(T==NULL){
T=(Node *)malloc(sizeof(struct Node));
T->Element=x;
T->Left=NULL;
T->Right=NULL;
T->depth=count;
}
else if(x<=T->Element)
{
count++;
T->Left=Insert(x,T->Left);
}
else if(x>T->Element){
count++;
T->Right=Insert(x,T->Right);
}
if(count>max1)
max1=count;
return T;

}
void get(Tree T);
int main() {
Tree C=NULL;
int a;
cin >> a;
for(int i=0;i<a;i++){
int b;
cin >> b;
count=0;
C=Insert(b,C);
}
qq[0]=0;
qq[1]=0;
get(C);
cout << qq[0] <<" + "<< qq[1]<< " = "<< qq[0]+qq[1];
return 0;
}

void get(Tree T)
{
if(T->depth==max1)
qq[0]++;
if(T->depth==(max1-1))
qq[1]++;
if(T->Left!=NULL)
get(T->Left);
if(T->Right!=NULL)
get(T->Right);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pta