您的位置:首页 > 其它

A1056. Mice and Rice (25)

2016-12-02 20:08 162 查看
Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NG winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (<= 1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG mice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,…NP-1) where each Wi is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,…NP-1 (assume that the programmers are numbered from 0 to NP-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3

25 18 0 46 37 3 19 22 57 56 10

6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

时间限制

30 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

知识点

#include<quequ>
using namespace std;

queue<int> q;//定义一个序列
// 插入队列
q.push(s1);
// 取出队首元素
MyStruct s1_copy = q.front();
// 队首元素从队列中移除
q.pop();


队列里,前ng个中挨个pop,比较出最大的,把序号记下来并push进去序号。

goup只老鼠,排名为group+1,晋级group只老鼠。

三层循环,第一层算组数,第二层遍历各个组,第三层遍历每个组的元素。

如果不够一个组的,也要把各个元素遍历了并pop出来。

#include<cstdio>
#include<queue>
using namespace std;
const int maxn=1010;
struct mouse{
int weight;
int R;//rank
}mouse[maxn];
int main()
{
int np,ng,i,order;
scanf("%d%d",&np,&ng);//np,老鼠数量;ng,每组老鼠数
for(i=0;i<np;i++)
{
scanf("%d%",&mouse[i].weight);
}
queue<int> q;
for(i=0;i<np;i++)
{
scanf("%d%",&order);
q.push(order);//顺序号入队
}
int temp=np,group;//temp为当前轮比赛总老鼠数,group组数
while(q.size()!=1)
{   if(temp%ng==0)group=temp/ng;
else group=temp/ng+1;//确定组数
for(i=1;i<=group;i++)//遍历各个组
{
int k=q.front();//k记录最大的重量
for(int j=1;j<=ng;j++)//遍历每组老鼠
{
if((i-1)*ng+j-1>=temp) break;
int front=q.front();//front为当前老鼠序号
if(mouse[k].weight<mouse[front].weight)
k=front;
mouse[front].R=group+1;
q.pop();
}
q.push(k);

}
temp=group;
}
mouse[q.front()].R=1;

for(i=0;i<np;i++)
{
printf("%d",mouse[i].R);
if(i!=np-1)printf(" ");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat 队列