您的位置:首页 > 其它

HDU1016 Prime Ring Problem(素数环,深搜DFS)

2016-12-02 17:37 363 查看
题目:


Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 45061    Accepted Submission(s): 19969


Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



 

Input

n (0 < n < 20).

 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

 

Sample Input

6
8

 

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

 

思路:

利用搜索,枚举每一种可能,然后把符合条件的输出

代码:

#include <stdio.h>
#include <string.h>
#define mem(a,b) memset(a,b,sizeof(a))
int prime[100]= {1,1};
int a[50],md[50],n;//a来存放素数环里的数,md是做标记
void sushu()
{
int i,j;
for(i=2; i<=10; i++)
if(prime[i]==0)
for(j=2*i; j<=50; j+=i)
prime[j]=1;//把不是素数的标记为1
}
void dfs(int step)
{
int i,j;
if(step==n+1&&prime[a
+a[1]]==0)//结束条件,这个代码是从a[1]开始的
{
for(i=1; i<n; i++)
printf("%d ",a[i]);
printf("%d\n",a
);
return;
}
for(i=2; i<=n; i++)
{
if(md[i]==0&&prime[i+a[step-1]]==0)
{
a[step]=i;//给素数环填数
md[i]=1;//标记一下走过的
dfs(step+1);//搜索下一步
md[i]=0;//标记回来
}
}
return;
}
int main()
{
int num=1;
a[1]=1;//从1开始的
sushu();
while(~scanf("%d",&n))
{
mem(md,0);
printf("Case %d:\n",num++);
dfs(2);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: