您的位置:首页 > 其它

hdu 1058 dp.Humble Numbers

2016-11-17 13:47 453 查看
Humble Numbers
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit Status Practice HDU
1058

Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence 

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n. 

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output. 

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0


Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.


#include <iostream>
#include <stdio.h>
using namespace std;
int f[5843],n;
int i,j,k,l;

int min(int a,int b,int c,int d)
{
int min=a;
if(b<min) min=b;
if(c<min) min=c;
if(d<min) min=d;

if(a==min) i++;
if(b==min) j++;
if(c==min) k++;
if(d==min) l++;

return min;//a或b或c或d
}

int main()
{
i=j=k=l=1;
f[1]=1;
for(int t=2; t<=5842; t++)
{
f[t]=min(2*f[i],3*f[j],5*f[k],7*f[l]);
}
while(scanf("%d",&n)&&n!=0)
{
if(n%10==1&&n%100!=11)
printf("The %dst humble number is %d.\n",n,f
);
else if(n%10==2&&n%100!=12)
printf("The %dnd humble number is %d.\n",n,f
);
else if(n%10==3&&n%100!=13)
printf("The %drd humble number is %d.\n",n,f
);
else
printf("The %dth humble number is %d.\n",n,f
);
}
return 1;
}

//#include<stdio.h>
//#define min(a,b) (a<b?a:b)
//#define min4(a,b,c,d) min(min(a,b),min(c,d))
//int a[5850];//存放丑数
//
//int main()
//{
//    int n=1;
//    int p2,p3,p5,p7;
//    p2=p3=p5=p7=1;//2,3,5,7的计数器
//    a[1]=1;
//    while(a
<2000000000)//从2开始递推计算,一共5842个丑数
//    {
//        a[++n] = min4(2*a[p2],3*a[p3],5*a[p5],7*a[p7]);//取最小值,相应的计数器加1
//        if(a
==2*a[p2]) p2++;
//        if(a
==3*a[p3]) p3++;
//        if(a
==5*a[p5]) p5++;
//        if(a
==7*a[p7]) p7++;
//    }
//    while(scanf("%d",&n) && n)
//    {
//        if(n%10 == 1&&n%100!=11)
//            printf("The %dst humble number is ",n);
//        else if(n%10 == 2&&n%100!=12)
//            printf("The %dnd humble number is ",n);
//        else if(n%10 == 3&&n%100!=13)
//            printf("The %drd humble number is ",n);
//        else
//            printf("The %dth humble number is ",n);
//        printf("%d.\n",a
);
//    }
//    return 0;
//
//}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: