您的位置:首页 > 其它

HDU 5945 Fxx and game (DP+单调队列优化)

2016-11-10 17:08 555 查看

Fxx and game

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)

Total Submission(s): 1339    Accepted Submission(s): 358

[align=left]Problem Description[/align]
Young theoretical computer scientist Fxx designed a game for his students.

In each game, you will get three integers X,k,t.In
each step, you can only do one of the following moves:

1.X=X−i(0<=i<=t).

2.ifk|X,X=X/k.

Now Fxx wants you to tell him the minimum steps to make
X
become 1.

 

[align=left]Input[/align]
In the first line, there is an integer
T(1≤T≤20)ru
indicating the number of test cases.

As for the following T
lines, each line contains three integers X,k,t(0≤t≤106,1≤X,k≤106)

For each text case,we assure that it's possible to make
X
become 1。

 

[align=left]Output[/align]
For each test case, output the answer.

 

[align=left]Sample Input[/align]

2
9 2 1
11 3 3

 

[align=left]Sample Output[/align]

4
3

 

[align=left]Source[/align]
BestCoder Round #89 
 
题意:
    给你一个数X,对这个X有两种操作:1,X-i (0<i<=t)  2,如果X%k==0   X/=k  问你最少操作多少次可以使X变成1
刚开始以为是贪心,结果发现被HANK掉了,后来看题解是道DP,很好找到状态和状态转移方程,dp[i]表示为1到i的最小操作次数,dp[i]=min(dp[i-k])(1<=k<=t).如果i%k==0,
dp[i]=min(dp[i],dp[i/k]). 但是这样时间复杂度会到达O(X*t)明显超时,只好用单调队列优化。(至于单调队列,不懂的话去百度吧。)

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <stack>
#include <map>
#include <set>
#include <queue>
#include <vector>
#define inf 0x6fffffff
#define LL long long
#define mem(p,k) memset(p,k,sizeof(p));
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;

int dp[1000005],que[1000005];

int main()
{
int m;
cin>>m;
while(m--){
int x,k,t,head=1,tail=1;
cin>>x>>k>>t;
if(x==1){
cout<<0<<endl;
continue;
}
if(t>=x-1){
cout<<1<<endl;continue;
}
if(t==0){
int sum=0;
while(x!=1){
x/=2;
sum++;
}
cout<<sum<<endl;continue;
}
mem(que,0);
mem(dp,0);
que[tail++]=1;
for(int i=2;i<=x;i++){
while(tail>head&&i-t>que[head])head++;
if(tail>head)dp[i]=dp[que[head]]+1;
if(i%k==0)dp[i]=min(dp[i],dp[i/k]+1);

while(tail>head&&dp[i]<dp[que[tail-1]])tail--;
que[tail++]=i;
// cout<<i<<" ";
}
cout<<dp[x]<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: