您的位置:首页 > 其它

poj 3159 Candies(查分约束+堆栈优化的spfa最短路模板)

2016-11-08 21:13 309 查看
题目链接:点击打开链接

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers
of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies
fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another
bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N.
snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that kid A believed that kid B should never get over c candies
more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input
2 2
1 2 5
2 1 4

Sample Output
5

Hint

32-bit signed integer type is capable of doing all arithmetic.
题目大意:一个班里要分糖果,A同学认为自己分的糖果数要比B同学的糖果数最多少k个,也就是dist[B]-dist[A]<=k,求最大的不同,即从1到n的最短路

ps:由于数据问题,要求的算法比较复杂,用到的为spfa而且是用stack优化的,直接套用他的模板吧,,,建图比较优化,很巧妙,看了好久它的原理

<pre name="code" class="cpp">#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<stack>
#define INF 0x3f3f3f3f

using namespace std ;

struct node
{
int v,w,next;

}q[150005];

int mp[30005];
bool vis[30005];
int n,m;
int dist[30005];
void spfa()
{
for(int i=2;i<=n;i++)///初始化为最大
{
dist[i]=INF;
}
memset(vis,false,sizeof(vis));
dist[1]=0;///起始点为1,赋值为0
stack<int >s;///堆栈spfa模板
s.push(1);
vis[1]=true;

while(!s.empty())
{
int u=s.top();
s.pop();

for(int i=mp[u];i!=0;i=q[i].next)
{
int v=q[i].v;
if(dist[v]>dist[u]+q[i].w)
{
dist[v]=dist[u]+q[i].w;
if(!vis[v])
{
vis[v]=1;
s.push(v);
}
}
}
vis[u]=0;
}
printf("%d\n",dist
);
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
int x,y,z;
memset(mp,0,sizeof(mp));
for(int i=0,j=1;i<m;i++)
{
scanf("%d%d%d",&x,&y,&z);
q[j].v=y;
q[j].w=z;
q[j].next=mp[x];
mp[x]=j++;
}
spfa();
}
return 0;
}




                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: