您的位置:首页 > 其它

HDU 5935 Car 【模拟】 (2016年中国大学生程序设计竞赛(杭州))

2016-10-29 17:41 549 查看


Car

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 25    Accepted Submission(s): 12

Problem Description

Ruins is driving a car to participating in a programming contest. As on a very tight schedule, he will drive the car without any slow down, so the speed of the car is non-decrease real number.

Of course, his speeding caught
18306
the attention of the traffic police. Police record N positions
of Ruins without time mark, the only thing they know is every position is recorded at an integer time point and Ruins started at 0.

Now they want to know the minimum time that Ruins used to pass the last position.

 

Input

First line contains an integer T,
which indicates the number of test cases.

Every test case begins with an integers N,
which is the number of the recorded positions.

The second line contains N numbers a1, a2, ⋯, aN,
indicating the recorded positions.

Limits
1≤T≤100
1≤N≤105
0<ai≤109
ai<ai+1

 

Output

For every test case, you should output 'Case #x: y', where x indicates the case number and counts from 1 and y is the minimum time.

 

Sample Input

1
3
6 11 21

 

Sample Output

Case #1: 4

 

Source

2016年中国大学生程序设计竞赛(杭州)

 

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  5943 5942 5941 5940 5939 

 

Statistic | Submit | Discuss | Note

题目链接:

  http://acm.hdu.edu.cn/showproblem.php?pid=5935


题目大意:

  一辆车,从t=0开始走,速度只能递增,可为小数。警察在t为整数的时候记录了N个车的位置(整数),问到达最后一个位置时这辆车总共开了多久。

题目思路:

  【模拟】

  首先可以知道答案必为整数,并且每一段距离都是匀速的。

  从后往前看,最后一段距离X
-X[N-1]必然花了t=1s的时间(没有约束条件,速度可以任意加),V=X
-X[N-1]。

  那么在它之前的距离X‘,只要满足速度V‘<V即可,那么把X’均分成t段,每段时间为1,行走距离V‘,只要V’*t恰好>X‘即可。

  这样往前递推,每一段的速度都不能超过前面。

  注意精度问题。

//
//by coolxxx
//#include<bits/stdc++.h>
#include<iostream>
#include<algorithm>
#include<string>
#include<iomanip>
#include<map>
#include<stack>
#include<queue>
#include<set>
#include<bitset>
#include<memory.h>
#include<time.h>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
//#include<stdbool.h>
#include<math.h>
#pragma comment(linker,"/STACK:1024000000,1024000000")
#define min(a,b) ((a)<(b)?(a):(b))
#define max(a,b) ((a)>(b)?(a):(b))
#define abs(a) ((a)>0?(a):(-(a)))
#define lowbit(a) (a&(-a))
#define sqr(a) ((a)*(a))
#define swap(a,b) ((a)^=(b),(b)^=(a),(a)^=(b))
#define mem(a,b) memset(a,b,sizeof(a))
#define eps (1e-8)
#define J 10000
#define mod 1000000007
#define MAX 0x7f7f7f7f
#define PI 3.14159265358979323
#define N 100004
using namespace std;
typedef long long LL;
double anss;
LL aans;
int cas,cass;
int n,m,lll,ans;
int a
;
double v;
int main()
{
#ifndef ONLINE_JUDGEW
// freopen("1.txt","r",stdin);
// freopen("2.txt","w",stdout);
#endif
int i,j,k;
int x,y,z;
// init();
// for(scanf("%d",&cass);cass;cass--)
for(scanf("%d",&cas),cass=1;cass<=cas;cass++)
// while(~scanf("%s",s))
// while(~scanf("%d%d",&n,&m))
{
ans=1;
printf("Case #%d: ",cass);
scanf("%d",&n);
for(i=1;i<=n;i++)
scanf("%d",&a[i]);
v=a
-a[n-1];
for(i=n-1;i;i--)
{
x=a[i]-a[i-1];
if(x<=v+eps)
{
v=x;
ans++;
}
else
{
ans+=(int(double(x-eps)/v)+1);
v=(double(x)/(int(double(x-eps)/v)+1));
}
}
printf("%d\n",ans);
}
return 0;
}
/*
//

//
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐