您的位置:首页 > 编程语言 > C语言/C++

201312-1-出现次数最多的数

2016-10-29 13:44 183 查看
问题描述

  给定n个正整数,找出它们中出现次数最多的数。如果这样的数有多个,请输出其中最小的一个。

输入格式

  输入的第一行只有一个正整数n(1 ≤ n ≤ 1000),表示数字的个数。
  输入的第二行有n个整数s1, s2, …, sn (1 ≤ si ≤ 10000, 1 ≤ i ≤ n)。相邻的数用空格分隔。

输出格式

  输出这n个次数中出现次数最多的数。如果这样的数有多个,输出其中最小的一个。

样例输入

6

10 1 10 20 30 20

样例输出

10

解答代码

#include<iostream>
#include<cstring>
#include<set>
using namespace std;

int main()
{
set<int> s;
int i,n,data;
int test[10002];
while(cin>>n)
{
memset(test,0,sizeof(test));
for(i=0;i<n;i++)
{
cin>>data;
test[data]++;
}
int maxRes=0;
int maxIndex=0;
for(i=0;i<10002;i++)
{
if(test[i]>maxRes)
{
maxRes=test[i];
maxIndex=i;
}
}
cout<<maxIndex<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息