您的位置:首页 > 其它

hdu-1241 Oil Deposits(DFS)

2016-10-24 17:52 309 查看

hdu-1241 Oil Deposits(DFS)

题目描述

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 25664 Accepted Submission(s): 14776

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either
*', representing the absence of oil, or
@’, representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0


Sample Output

0
1
2
2


题目理解

​ ‘@’用来表示油田,’*’则表示普通土地,相邻的’@’块被认为是一整块油藏,这里的相邻包括8个方向,及上下左右,斜上方斜下方(各包含两个方向)。可以直接使用DFS求解,求解时,将相邻的油田修改标记为’*’,如此,每次遇到另一个’@’则可认为是一个新的油田或油藏。具体思路可结合下方代码中的注释一起理解。

代码

//
//  main.cpp
//  hdu1241
//
//  Created by Morris on 2016/10/24.
//  Copyright © 2016年 Morris. All rights reserved.
//

#include <cstdio>

#define MAX_SZ 101

namespace {
using std::scanf;
using std::printf;
}

int cnt = 0;
int m, n;
char map[MAX_SZ][MAX_SZ] = { 0 };

/* 定义8个方向 */
int dir[8][2] = { { -1, 0 }, { 1, 0 }, { 0, -1 }, { 0, 1 },
{ -1, -1 }, { -1, 1 }, { 1, -1 }, { 1, 1 } };

void dfs(int x, int y);

int main(int argc, const char *argv[])
{
int i, j;
while (~scanf("%d%d", &m, &n)) {
if (m == 0 && n == 0) {
break;
}
cnt = 0;
for (i = 0; i < m; ++i) {
scanf("%s", map[i]);
}

for (i = 0; i < m; ++i) {
for (j = 0; j < n; ++j) {
if (map[i][j] == '@') {
++cnt;
dfs(i, j);  /* 通过dfs修改相邻的油田标记,若再遇到'@'即可认为 */
/* 是新油田或油藏 */
}
}
}

printf("%d\n", cnt);
}

return 0;
}

void dfs(int x, int y)
{
map[x][y] = '*';  /* 修改油田标记 */
int i;
for (i = 0; i < 8; ++i) {
int tx = x + dir[i][0];
int ty = y + dir[i][1];

if (tx >= 0 && tx < m && ty >= 0 && ty < n) {  /* 防止越界 */
if (map[tx][ty] == '@') {
dfs(tx, ty);
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  dfs hdu acm