您的位置:首页 > 其它

POJ1330 Nearest Common Ancestors[LCA]

2016-10-17 14:07 447 查看
Nearest Common Ancestors

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 26637 Accepted: 13746

Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:

In the figure, each node is labeled with an integer from {1, 2,…,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y.

Write a program that finds the nearest common ancestor of two distinct nodes in a tree.

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,…, N. Each of the next N -1 lines contains a pair of integers that represent an edge –the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2

16

1 14

8 5

10 16

5 9

4 6

8 4

4 10

1 13

6 15

10 11

6 7

10 2

16 3

8 1

16 12

16 7

5

2 3

3 4

3 1

1 5

3 5

Sample Output

4

3

Source

Taejon 2002

题意:求LCA;

分析:本来觉得只求一次不是很LCA…不过确认了一下的确是LCA模板题。练手,打算用两个方法来做:

1.在线RMQ,感觉写起来很顺手

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define clr(x) memset(x,0,sizeof(x))
using namespace std;
const int maxn=1e4+5;
int n,tii[maxn*2],cnt,inde,fr[maxn],tov[maxn],des[maxn],sig[maxn],f[maxn*2*2][15],rd[maxn];
int sta,fin,m,a[maxn],t;
char tmp;
void addedge()
{
tov[++inde]=fr[sta];fr[sta]=inde;des[inde]=fin;rd[fin]++;
}
void dfs(int u)
{
f[++cnt][0]=cnt;
tii[cnt]=u;
sig[u]=cnt;
for(int i=fr[u];i;i=tov[i]){
dfs(des[i]);
f[++cnt][0]=sig[u];
}
}
int poww(int c)
{
int tmp=2;
for(int i=1;i<c;i++)tmp*=2;
if(!c)return 1;
return tmp;
}
void  init()
{
scanf("%d",&n);
cnt=inde=0;clr(fr);
clr(f);clr(rd);
for(int i=1;i<n;i++){
scanf("%d",&sta);
scanf("%d",&fin);
addedge();
}
for(int i=1;i<=n;i++)
if(!rd[i])dfs(i);
for(int i=1;i<=14;i++)
for(int j=1;j<=cnt;j++)
f[j][i]=min(f[j][i-1],f[j+poww(i-1)][i-1]);
}
void query()
{
if(sig[sta]>sig[fin])swap(sta,fin);
int logg=floor(log(sig[fin]-sig[sta]+1)/log(2));
int mini;
mini=min(f[sig[sta]][logg],f[sig[fin]-poww(logg)+1][logg]);
printf("%d\n",tii[mini]);
}
void work()
{
scanf("%d %d",&sta,&fin);
query();
}
int main()
{
freopen("poj1330.in","r",stdin);
freopen("poj1330.out","w",stdout);
scanf("%d",&t);
while(t--){
init();
work();
}
return 0;
}


2.离线tarjan:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define clr(x) memset(x,0,sizeof(x))
using namespace std;
const int maxn=1e4+5;
int n,inde,fr[maxn],tov[maxn],des[maxn],sig[maxn],fath[maxn];
int sta,fin,m,a[maxn],t,mini,used[maxn],rd[maxn];
void addedge()
{
tov[++inde]=fr[sta];fr[sta]=inde;des[inde]=fin;rd[fin]++;
}
int fa(int u)
{
return fath[u]==u?u:fa(fath[u]);
}
void unio(int a,int b){
a=fa(a);b=fa(b);
fath[a]=b;
}
void dfs(int u)
{
for(int i=fr[u];i;i=tov[i]){
dfs(des[i]);unio(des[i],u);}
if(u==sta&&used[fin])mini=fa(fin);
if(u==fin&&used[sta])mini=fa(sta);
used[u]=1;
}
void  init()
{
scanf("%d",&n);
inde=0;clr(fr);clr(used);clr(rd);
for(int i=1;i<=n;i++)
fath[i]=i;
for(int i=1;i<n;i++){
scanf("%d",&sta);
scanf("%d",&fin);
addedge();
}
}
void work()
{
scanf("%d %d",&sta,&fin);
for(int i=1;i<=n;i++)
if(!rd[i])dfs(i);
printf("%d\n",mini);
}
int main()
{
freopen("poj1330.in","r",stdin);
freopen("poj1330.out","w",stdout);
scanf("%d",&t);
while(t--){
init();
work();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  LCA POJ POJ1330