您的位置:首页 > 其它

HDU 5536 2015ACM-ICPC长春赛区现场赛J题

2016-10-16 14:17 253 查看
Chip Factory

Time Limit: 18000/9000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)

Total Submission(s): 2236 Accepted Submission(s): 983

Problem Description

John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces n chips today, the i-th chip produced this day has a serial number si.

At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below:

max[i,j,k] (si+sj)⊕sk

which i,j,k are three different integers between 1 and n. And ⊕ is symbol of bitwise XOR.

Can you help John calculate the checksum number of today?

Input

The first line of input contains an integer T indicating the total number of test cases.

The first line of each test case is an integer n, indicating the number of chips produced today. The next line has n integers s1,s2,..,sn, separated with single space, indicating serial number of each chip.

1≤T≤1000

3≤n≤1000

0≤si≤109

There are at most 10 testcases with n>100

Output

For each test case, please output an integer indicating the checksum number in a line.

Sample Input

2

3

1 2 3

3

100 200 300

Sample Output

6

400

Source

2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)

题意

给定一个序列,找出(si+sj)⊕sk最大值,i j k 均不同

思路

n^3能过,数据太水

正解是字典树

把序列中每个值按2进制从左往右插入字典树,n^2枚举si,sj ,将si,sj暂时在字典树中删去,之后在树上构造一个和si+sj每位异或为1的值,如果没有,再选择0,最后将si,sj还原回字典树

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int ch[100010][2];
int val[100010];
int s[1010];
int sz;
int n;
void init()
{
sz=1;
memset(ch[0],0,sizeof(ch[0]));
}

//d=1表示插入
//d=-1表示删除
void insert(int v,int d)
{
int u=0;
for(int i=30;i>=0;i--)
{
int c=(v>>i)&1;
if(!ch[u][c])
{
memset(ch[sz],0,sizeof(ch[sz]));
val[sz]=0;
ch[u][c]=sz++;
}
u=ch[u][c];
val[u]+=d;
}
}

int match(int v)
{
int u=0,ans=0;
for(int i=30;i>=0;i--)
{
int c=(v>>i)&1;
if(ch[u][c^1]&&val[ch[u][c^1]])
{
ans|=1<<i;
u=ch[u][c^1];
}
else u=ch[u][c];
}
return ans;
}

int main()
{
int T;
int n;
scanf("%d",&T);
while(T--)
{
init();
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
scanf("%d",&s[i]);
insert(s[i],1);
}
int ans=(s[1]+s[2])^s[3];
for(int i=1;i<n;i++)
{
insert(s[i],-1);
for(int j=i+1;j<=n;j++)
{
insert(s[j],-1);
int t=match(s[i]+s[j]);
ans=max(ans,t);
insert(s[j],1);
}
insert(s[i],1);
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息