您的位置:首页 > 其它

浙大 PAT 甲级1009

2016-10-14 20:53 369 查看


1009. Product of Polynomials (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 3 3.6 2 6.0 1 1.6

#include<stdio.h>
int main(){
double a[1001]={0.0},b[2001]={0.0},t;  //开两个数组,前一个存第一个多项式,下标为次数,值为系数, 后一个要大一些防止越界,并且直接存储结果。
int  n1,n2,m,n,i,j;
scanf("%d",&n1);
for(i=0;i<n1;i++){
scanf("%d %lf",&m,&t);
a[m]=t;
}
scanf("%d",&n2);
for(i=0;i<n2;i++){
scanf("%d %lf",&m,&t);
for(j=0;j<1001;j++){
if(a[j]!=0.0){
b[m+j]+=a[j]*t;           //这里就是模拟多项式乘法的关键!!
}
}
}
j=0;
for(i=0;i<2001;i++){
if(b[i]!=0.0)
j++;
}
printf("%d",j);
for(i=2000;i>=0;i--){
if(b[i]!=0.0)
printf(" %d %.1lf",i,b[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: