您的位置:首页 > 其它

Codeforces Intel Code Challenge Final Round (Div. 1 + Div. 2, Combined) B. Batch Sort(暴力)

2016-10-10 20:14 627 查看
传送门

Description

You are given a table consisting of n rows and m columns.

Numbers in each row form a permutation of integers from 1 to m.

You are allowed to pick two elements in one row and swap them, but no more than once for each row. Also, no more than once you are allowed to pick two columns and swap them. Thus, you are allowed to perform from 0 to n + 1 actions in total. Operations can be performed in any order.

You have to check whether it's possible to obtain the identity permutation 1, 2, ..., m in each row. In other words, check if one can perform some of the operation following the given rules and make each row sorted in increasing order.

Input

The first line of the input contains two integers n and m (1 ≤ n, m ≤ 20) — the number of rows and the number of columns in the given table.

Each of next n lines contains m integers — elements of the table. It's guaranteed that numbers in each line form a permutation of integers from 1 to m.

Output

If there is a way to obtain the identity permutation in each row by following the given rules, print "YES" (without quotes) in the only line of the output. Otherwise, print "NO" (without quotes).

Sample Input

2 4
1 3 2 4
1 3 4 2

4 4
1 2 3 4
2 3 4 1
3 4 1 2
4 1 2 3

3 6
2 1 3 4 5 6
1 2 4 3 5 6
1 2 3 4 6 5


Sample Output

YES

NO

YES


思路

题意:给你一个NxM的矩阵块,每行都是数字1-M的一个排列,对于行,每行只允许交换两个数的位置一次,对于列,只允许交换两列一次,最多可交换次数为N + 1次,问有没有可能在允许的交换操作下使得每行都是上升序列。

数据范围很小,考虑暴力解。首先判断是否能只通过行操作,达到目的,不行的话,枚举列交换,然后在判断能否通过行操作达到目的。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 25;

bool solve(int a[][maxn],int N,int M,int c1,int c2)
{
int atmp[maxn][maxn];
for (int i = 0;i < N;i++)	for (int j = 0;j < M;j++)	atmp[i][j] = a[i][j];
for (int i = 0;i < N;i++)	swap(atmp[i][c1],atmp[i][c2]);
for (int i = 0;i < N;i++)
{
int cnt = 0;
for (int j = 0;j < M;j++)
{
if (atmp[i][j] != j + 1)	cnt++;
}
if (cnt > 2)	return false;
}
return true;
}

int main()
{
int N,M,a[maxn][maxn];
while (~scanf("%d%d",&N,&M))
{
for (int i = 0;i < N;i++)	for (int j = 0;j < M;j++)	scanf("%d",&a[i][j]);
bool flag = false;
for (int i = 0;i < M - 1;i++)
{
for (int j = i + 1;j < M;j++)
{
flag = solve(a,N,M,i,j);
if (flag)	break;
}
if (flag)	break;
}
if (flag)	printf("YES\n");
else
{
int cnt = 0;
for (int i = 0;i < N;i++)
{
cnt = 0;
for (int j = 0;j < M;j++)
{
if (a[i][j] != j + 1)	cnt++;
if (cnt > 2)	break;
}
if (cnt > 2)	break;
}
if (cnt > 2)	printf("NO\n");
else	printf("YES\n");
}
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐