您的位置:首页 > 其它

顺序表应用1:多余元素删除之移位算法

2016-10-08 11:15 375 查看


顺序表应用1:多余元素删除之移位算法

Time Limit: 1000MS Memory Limit: 650KB

Submit Statistic


Problem Description

一个长度不超过10000数据的顺序表,可能存在着一些值相同的“多余”数据元素(类型为整型),编写一个程序将“多余”的数据元素从顺序表中删除,使该表由一个“非纯表”(值相同的元素在表中可能有多个)变成一个“纯表”(值相同的元素在表中只保留第一个)。

要求:

       1、必须先定义线性表的结构与操作函数,在主函数中借助该定义与操作函数调用实现问题功能;

       2、本题的目标是熟悉顺序表的移位算法,因此题目必须要用元素的移位实现删除;


Input

 第一行输入整数n,代表下面有n行输入;

之后输入n行,每行先输入整数m,之后输入m个数据,代表对应顺序表的每个元素。


Output

 输出有n行,为每个顺序表删除多余元素后的结果


Example Input

4
5 6 9 6 8 9
3 5 5 5
5 9 8 7 6 5
10 1 2 3 4 5 5 4 2 1 3



Example Output

6 9 8
5
9 8 7 6 5
1 2 3 4 5

#include <iostream>

using namespace std;
typedef struct
{
int *elem;
int len;
}List;
void creat(List &l,int n)
{
l.elem=new int [1001];
l.len = 0;
for(int i=0; i < n; i++)
{
cin>>l.elem[i];
l.len++;
}

}

void deletelist(List &l)
{
int n=0;
while(n<l.len-1)
{
for(int i=n+1;i<l.len;i++)
{
if(l.elem
==l.elem[i])
{
for(int j=i;j<l.len-1;j++)
{
l.elem[j]=l.elem[j+1];
}
l.len--;
i--;
}
}
n++;
}
}

int main()
{
int n,m;
cin>>m;
while(m--)
{
cin>>n;
List l;
creat(l,n);
deletelist(l);
//cout<<l.len<<endl;
for(int i=0;i<l.len;i++)
{
if(i==l.len-1)
cout<<l.elem[i]<<endl;
else
cout<<l.elem[i]<<" ";
}
}
return 0;
}

/***************************************************

Result: Accepted
Take time: 44ms
Take Memory: 204KB
Submit time: 2016-09-19 19:16:19
****************************************************/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: