您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表二:逆序建立链表

2016-10-07 20:59 232 查看


数据结构实验之链表二:逆序建立链表

Time Limit: 1000MS
Memory Limit: 65536KB
Submit

Statistic

Problem Description

输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。

Input

第一行输入整数N;;

第二行依次输入N个整数,逆序建立单链表。

Output

依次输出单链表所存放的数据。

Example Input

10
11 3 5 27 9 12 43 16 84 22


Example Output

22 84 16 43 12 9 27 5 3 11


Hint

不能使用数组!

Author

01
#include<iostream>
02
using
namespace
std;
03
class
node
04
{
05
    
public
:
06
        
int

data;
07
        
node * next;
08
};
09
node * creat(
int

n)
10
{
11
    
int

i;
12
    
node *head,*p;
13
    
head =
new
node;
14
    
head->next = NULL;
15
    
for
(i = 1; i <= n; i ++)
16
    
{
17
        
p =
new
node;
18
        
cin >>p->data;
19
        
p->next = head->next;
20
        
head->next = p;
21
    
}
22
    
return

head;
23
}
24
void
print(node *head)
25
{
26
    
node *p;
27
    
p = head->next;
28
    
while
(p->next)
29
    
{
30
        
cout <<p->data<<
' '
;
31
        
p = p->next;
32
    
}
33
    
cout <<p->data<<endl;
34
}
35
int
main()
36
{
37
    
node *head;
38
    
int

n;
39
    
cin >>n;
40
    
head = creat(n);
41
    
print(head);
42
    
return

0;
43
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: