您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表二:逆序建立链表

2016-09-27 18:10 155 查看


数据结构实验之链表二:逆序建立链表

Time Limit: 1000MS Memory Limit: 65536KB


Problem Description

输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。


Input

第一行输入整数N;;

第二行依次输入N个整数,逆序建立单链表。


Output

依次输出单链表所存放的数据。


Example Input

10
11 3 5 27 9 12 43 16 84 22



Example Output

22 84 16 43 12 9 27 5 3 11




Code realization

#include <stdio.h>
#include <stdlib.h>
typedef int elemtype;
typedef struct LNode
{
elemtype data;
struct LNode *next;
}LNode,*LinkList;
int main()
{
int n, i;
LinkList p, head, tail;
scanf("%d",&n);
tail = (LNode*)malloc(sizeof(LNode));
tail->next = NULL;
head = tail;
for(i=0;i<n;i++)
{
p = (LNode*)malloc(sizeof(LNode));
scanf("%d",&p->data);
p->next = head;
head = p;
}
for(i=0;i<n;i++)
{
if(i==n-1)
printf("%d\n",p->data);
else
printf("%d ",p->data);
p=p->next;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: