您的位置:首页 > 其它

HDU 5878 I Count Two Three 2016青岛网赛

2016-09-17 19:25 357 查看
I Count Two Three
Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 69    Accepted Submission(s): 44

Problem Description
I will show you the most popular board game in the Shanghai Ingress Resistance Team.
It all started several months ago.
We found out the home address of the enlightened agent Icount2three and decided to draw him out.
Millions of missiles were detonated, but some of them failed.

After the event,
4000
we analysed the laws of failed attacks.
It's interesting that the i-th attacks failed if and only if i can be rewritten as the form of 2a3b5c7d which a,b,c,d are non-negative integers.

At recent dinner parties, we call the integers with the form 2a3b5c7d "I Count Two Three Numbers".
A related board game with a given positive integer n from one agent, asks all participants the smallest "I Count Two Three Number" no smaller than n.

Input
The first line of input contains an integer t (1≤t≤500000), the number of test cases. t test cases follow. Each test case provides one integer n (1≤n≤109).

Output
For each test case, output one line with only one integer corresponding to the shortest "I Count Two Three Number" no smaller than n.

Sample Input

10
1
11
13
123
1234
12345
123456
1234567
12345678
123456789

Sample Output

1
12
14
125
1250
12348
123480
1234800
12348000
123480000


刚看这题 感觉似曾相识….被队友一提醒 不就是HDU的Humble Numbers么

http://acm.split.hdu.edu.cn/showproblem.php?pid=1058

d[i]表示第i个丑数

a0=a1=a2=a3=0

显然d[1]=1;

d[i]=min(d[a0]*2,d[a1]*3,d[a2]*5,d[a3]*7)

if(d[i]==d[a0]*2)

++a0;

……

if(d[i]==d[a3]*7)

++a3;

打个表就可以了

#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<string>
#include<vector>
#include<deque>
#include<queue>
#include<algorithm>
#include<set>
#include<map>
#include<stack>
#include<time.h>
#include<math.h>
#include<list>
#include<cstring>
#include<fstream>
#include<bitset>
//#include<memory.h>
using namespace std;
#define ll long long
#define ull unsigned long long
#define pii pair<int,int>
#define INF 1000000007

int a[4];
vector<ll>vec;

int main()
{
//freopen("/home/lu/文档/r.txt","r",stdin);
//freopen("/home/lu/文档/w.txt","w",stdout);
vec.push_back(1);
const int N=1e9;
while(vec.back()<N){
ll t=vec[a[0]]*2;
t=min(t,vec[a[1]]*3);
t=min(t,vec[a[2]]*5);
t=min(t,vec[a[3]]*7);
if(t==vec[a[0]]*2)
++a[0];
if(t==vec[a[1]]*3)
++a[1];
if(t==vec[a[2]]*5)
++a[2];
if(t==vec[a[3]]*7)
++a[3];
vec.push_back(t);
}
int t,n;
scanf("%d",&t);
for(int i=0;i<t;++i){
scanf("%d",&n);
vector<ll>::iterator it=lower_bound(vec.begin(),vec.end(),n);
printf("%d\n",(int)*it);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU 2016青岛网赛 DP