您的位置:首页 > 其它

POJ 1236 Network of Schools(强连通分量/Tarjan缩点)

2016-09-11 02:07 465 查看
传送门

Description

A number of schools are connected to a computer network. Agreements have been developed among those schools: each school maintains a list of schools to which it distributes software (the “receiving schools”). Note that if B is in the distribution list of school A, then A does not necessarily appear in the list of school B
You are to write a program that computes the minimal number of schools that must receive a copy of the new software in order for the software to reach all schools in the network according to the agreement (Subtask A). As a further task, we want to ensure that by sending the copy of new software to an arbitrary school, this software will reach all schools in the network. To achieve this goal we may have to extend the lists of receivers by new members. Compute the minimal number of extensions that have to be made so that whatever school we send the new software to, it will reach all other schools (Subtask B). One extension means introducing one new member into the list of receivers of one school.

Input

The first line contains an integer N: the number of schools in the network (2 <= N <= 100). The schools are identified by the first N positive integers. Each of the next N lines describes a list of receivers. The line i+1 contains the identifiers of the receivers of school i. Each list ends with a 0. An empty list contains a 0 alone in the line.

Output

Your program should write two lines to the standard output. The first line should contain one positive integer: the solution of subtask A. The second line should contain the solution of subtask B.

Sample Input

5
2 4 3 0
4 5 0
0
0
1 0

Sample Output

1
2

思路

题意:

N(2<=N <=100)个学校之间有单向的网络,每个学校得到一套软件后,可以通过单向网络向周边的学校传输,

1:初始至少需要向多少个学校发放软件,使得网络内所有的学校最终都能得到软件。

2,至少需要添加几条传输线路(边),使任意向一个学校发放软件后,经过若干次传送,网络内所有的学校最终都能得到软件。

分析:

首先找连通分量,然后看连通分量的入度为0点的总数,出度为0点的总数,那么问要向多少学校发放软件,就是入度为零的个数,这样才能保证所有点最终都能得到软件
第二问添加多少条边可以得到使整个图达到一个强连通分量,答案是入度为0的个数和出度为0的个数中最大的值。将这个图的所有子树找出来,然后将一棵子树的叶子结点(出度为0)连到另外一棵子树的根结点上(入度为0),这样将所有的叶子结点和根节点全部消掉之后,就可以得到一整个强连通分量,看最少多少条边,这样就是看叶子结点和根节点哪个多,即出度为0和入度为0哪个多

//入度数组indeg[]  出度数组outdeg[]
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 105;
struct Edge{
int v,next;
}edge[maxn*maxn];
int head[maxn],dfn[maxn],low[maxn],st[maxn],inst[maxn],belong[maxn],indeg[maxn],outdeg[maxn];
int tot,top,in,out,scc_cnt,index,N;

void init()
{
tot = top = scc_cnt = index = 0;
in = out = 0;
memset(head,-1,sizeof(head));	memset(inst,0,sizeof(inst));
memset(dfn,0,sizeof(dfn));		memset(low,0,sizeof(low));
memset(indeg,0,sizeof(indeg));	memset(outdeg,0,sizeof(outdeg));
}

void addedge(int u,int v)
{
edge[tot] = (Edge){v,head[u]};
head[u] = tot++;
}

void targin(int u)
{
int v;
dfn[u] = low[u] = ++index;
st[++top] = u;
inst[u] = 1;
for (int i = head[u];i != -1;i = edge[i].next)
{
v = edge[i].v;
if (!dfn[v])
{
targin(v);
low[u] = min(low[u],low[v]);
}
else if (inst[v])
low[u] = min(low[u],dfn[v]);
}
if (dfn[u] == low[u])
{
scc_cnt++;
do
{
v = st[top--];
inst[v] = 0;
belong[v] = scc_cnt;
}
while (u != v);
}
}

int main()
{
while (~scanf("%d",&N))
{
int v;
init();
for (int i = 1;i <= N;i++)
while (~scanf("%d",&v) && v)	addedge(i,v);
for (int i = 1;i <= N;i++)	if (!dfn[i])	targin(i);
for (int i = 1;i <= N;i++)
for (int j = head[i]; j != -1;j = edge[j].next)
{
v = edge[j].v;
if (belong[i] != belong[v])
{
indeg[belong[v]]++;
outdeg[belong[i]]++;
}
}
for (int i = 1;i <= scc_cnt;i++)
{
if (!indeg[i])	in++;
if (!outdeg[i])	out++;
}
if (scc_cnt == 1)	printf("1\n0\n");
else printf("%d\n%d\n",in,max(in,out));
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: