您的位置:首页 > 产品设计 > UI/UE

PAT 1051. Pop Sequence (25)(模拟stack,问你能否依靠stack输出给出的序列)

2016-09-09 09:37 489 查看

官网

1051. Pop Sequence (25)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5

1 2 3 4 5 6 7

3 2 1 7 5 6 4

7 6 5 4 3 2 1

5 6 4 3 7 2 1

1 7 6 5 4 3 2

Sample Output:

YES

NO

NO

YES

NO

题目大意

1.给定一个限制了大小为
m
stack
,和一个序列
1 2 ... N
,问你能否依靠这个
stack
输出给出的序列。

解题思路

1.用
stack
模拟,共分为俩种情况:

(1)来了一个数,这个数比堆顶元素大。这样,就必须把从比
pre(记录之前已经压入堆的最大的元素)+1
到这个数的所有元素都压入堆,这时候如果空间不够就报错,否则就模拟一下,在排出堆顶,并更新
pre


(2)这个数不比堆顶元素大。那么如果相等,则直接排出就是了,如果小,则先输出这个是不可能的了,则报错。

代码

#include<stack>
#include<cstdio>
using namespace std;
int num[1000+5];
int main(int argc, char *argv[])
{
int m,n,k;
scanf("%d %d %d",&m,&n,&k);
while (k--) {
stack<int> a;
for (int i = 0; i < n; ++i) {
scanf("%d",&num[i]);
}
int i;
bool isFindError = false;
int pre = 0;
for (i = 0; i < n; ++i) {
if (!a.empty()) {
//如果大于堆顶
if (a.top()<num[i]) {
//如果空间不够,报错
if (a.size()+num[i]-pre>m) {
printf("NO\n");
isFindError = true;
break;
}else {
//如果空间够,就模拟一下,先压入,再排出堆顶的
for (int j = pre+1; j <= num[i]; ++j) {
a.push(j);
}
pre = a.top();
a.pop();
}
}
//如果小于或等于堆顶
else {
if (a.top()==num[i]) {
a.pop();
}else {
printf("NO\n");
isFindError = true;
break;
}
}
}else {
if (num[i] - pre>m) {
printf("NO\n");
isFindError = true;
break;
}else {
//如果空间够,模拟一下
for (int j = pre + 1; j <= num[i]; ++j) {
a.push(j);
}
pre = a.top();
a.pop();
}

}
}
if (!isFindError) {
printf("YES\n");
}

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: