您的位置:首页 > 其它

POJ 2891 Strange Way to Express Integers 【中国剩余定理线性模方程合并(模板)】

2016-08-23 12:19 399 查看

Strange Way to Express Integers

Time Limit:1000MS Memory Limit:131072KB 64bit IO Format:%lld & %llu 
Description

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

Choose k different positive integers a1, a2, …, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find the remainder ri. If a1, a2, …, ak are properly chosen, m can be determined, then the pairs (ai, ri) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

Line 1: Contains the integer k.
Lines 2 ~ k + 1: Each contains a pair of integers ai, ri (1 ≤ i ≤ k).

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

Sample Input

2

8 7

11 9
Sample Output

31
Hint
All integers in the input and the output are non-negative and can be represented by 64-bit integral types.

题意:x=ai (mod mi) ,求x;

思路;孙子定理得mi两两互质,所以应该两两合并方程;

失误:死磕好几天终于理解一点了,还在exgcd上犯了个错;

代码如下:

#include<cstdio>
using namespace std;

typedef long long LL;

LL a[100000],m[100000];

LL exgcd(LL a,LL b,LL &x,LL &y)
{
if(!b)
{
x=1; y=0;
return a;
}
LL r=exgcd(b,a%b,y,x);
y-=x*(a/b);//y1=x2-a/b*y2 就是利用计算机int的除法
return r;
}

LL MCRT(LL a[],LL m[],LL N)//两个向量 维数
{
LL i=0,a1=a[1],m1=m[1];
for(i=2;i<=N;++i)
{
LL a2=a[i],m2=m[i];
LL x,y,c=a2-a1;
LL d=exgcd(m1,m2,x,y);
if(c%d) return -1;
LL K=x*c/d, mod=m2/d;;
K=(K%mod+mod)%mod;
a1+=m1*K;
m1*=mod;
}
return a1;
}

int main()
{
int N,i=0;
while(~scanf("%d",&N))
{
for(i=1;i<=N;++i)
{
scanf("%lld %lld",&m[i],&a[i]);
}
LL ans=MCRT(a,m,N);
printf("%lld\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐