您的位置:首页 > 其它

hdu1863-畅通工程 最小生成树的并查集实现方法

2016-08-18 16:08 260 查看
[align=left]hdu1863 ←杭电的域名换掉了,之前贴的链接都打不开[/align]
[align=left]找到一篇特别容易理解的用Kruskal博客[/align]

Problem Description

省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。

 

Input

测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N 

行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。

 

Output

对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。

 

Sample Input

3 3
1 2 1
1 3 2
2 3 4
1 3
2 3 2
0 100

 

Sample Output

3
?

最小生成树模板,利用了并查集(也可用Prim最小生成树算法)

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
const int MAXN = 111;
int Father[MAXN];
int N,M;
int Cost,flag;
void Initial()
{
for(int i = 0;i < MAXN;i++)
Father[i] = i;
Cost = 0;
flag = 0;
}
struct node{
int Start,End;//记录一条公路两端的村庄编号
int cost;//修这条公路的花费
}stu[111111];
bool cmp(node x,node y)
{
return x.cost < y.cost;
}
int Find(int x)
{
return x == Father[x] ? x : Find(Father[x]);
}
void Union(int x,int y)
{
x = Find(x);
y = Find(y);
if(x != y)
Father[x] = y;
}
bool Same(int x,int y)
{
return Find(x) == Find(y);
}
int main()
{
while(~scanf("%d",&N) && N)
{
Initial();
scanf("%d",&M);
for(int i = 0;i < N;i++)
scanf("%d%d%d",&stu[i].Start,&stu[i].End,&stu[i].cost);
sort(stu,stu+N,cmp);//根据花费从小到大排序
for(int i = 0;i < N;i++)
{
if(!Same(stu[i].Start,stu[i].End))//若两村庄间没有修公路,则建一条公路将他们连在一起
{
Cost += stu[i].cost;
Union(stu[i].Start,stu[i].End);//合并
}
}
for(int i = 1;i <= M;i++)
{
if(flag > 1)break;//当根节点的数目大于一的时候,说明公路不能将所有的村庄连在一起,输出 ?
if(Father[i] == i)
flag++;
}
if(flag > 1)printf("?\n");
else printf("%d\n",Cost);
}
return 0;
}


转载自点击打开链接
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: