您的位置:首页 > 其它

HDU 5821 乱搞

2016-08-11 18:18 375 查看

Ball

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)


[align=left]Problem Description[/align]
ZZX has a sequence of boxes numbered
1,2,...,n.
Each box can contain at most one ball.

You are given the initial configuration of the balls. For
1≤i≤n,
if the i-th
box is empty then a[i]=0,
otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished.

He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,...,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball)

He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal.

 

[align=left]Input[/align]
First line contains an integer t. Then t testcases follow.

In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],...,a
. Third line contains b[1],b[2],...,b
. Each of the next m lines contains two integers l[i],r[i].

1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000.

0<=a[i],b[i]<=n.

1<=l[i]<=r[i]<=n.
 

[align=left]Output[/align]
For each testcase, print "Yes" or "No" in a line.
 

[align=left]Sample Input[/align]

5
4 1
0 0 1 1
0 1 1 1
1 4
4 1
0 0 1 1
0 0 2 2
1 4
4 2
1 0 0 0
0 0 0 1
1 3
3 4
4 2
1 0 0 0
0 0 0 1
3 4
1 3
5 2
1 1 2 2 0
2 2 1 1 0
1 3
2 4

 

[align=left]Sample Output[/align]

No
No
Yes
No
Yes
题意:给你n个球的初始状态,目标状态,m个操作,每次操作可以把(l,r)区间的球取出来任意摆放,问可不可以变成最终状态。
题解:用结构体保存初始状态和目标状态的编号和数字,然后按数字大小排序,再定义新数组中每个值变为要到的下标位置,对于每次操作,sort即可,最后比较k[i]==i即可。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int n,m,k[1005];
struct node{
int v,p;
}a[1005],b[1005];

bool comp(node a,node b){
if(a.v==b.v)return a.p<b.p;
return a.v<b.v;
}

int main()
{
int t,i,j,x,y;
scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&m);
for(i=1;i<=n;i++){
scanf("%d",&a[i].v);
a[i].p=i;
}
for(i=1;i<=n;i++){
scanf("%d",&b[i].v);
b[i].p=i;
}
sort(a+1,a+n+1,comp);
sort(b+1,b+n+1,comp);
int flag=0;
for(i=1;i<=n;i++){
if(a[i].v!=b[i].v){
flag=1;
break;
}
k[a[i].p]=b[i].p;
}
for(i=1;i<=m;i++){
scanf("%d%d",&x,&y);
sort(k+x,k+y+1);
}
for(i=1;i<=n;i++){
if(k[i]!=i){
flag=1;break;
}
}
if(flag)printf("No\n");
else printf("Yes\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: