您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之查找三:树的种类统计(二叉排序树)

2016-08-11 09:53 309 查看

题目描述

随着卫星成像技术的应用,自然资源研究机构可以识别每一个棵树的种类。请编写程序帮助研究人员统计每种树的数量,计算每种树占总数的百分比。

输入

输入一组测试数据。数据的第1行给出一个正整数N (n
<= 100000),N表示树的数量;随后N行,每行给出卫星观测到的一棵树的种类名称,树的名称是一个不超过20个字符的字符串,字符串由英文字母和空格组成,不区分大小写。

输出

按字典序输出各种树的种类名称和它占的百分比,中间以空格间隔,小数点后保留两位小数。

示例输入

2
This is an Appletree
this is an appletree


示例输出

this is an appletree 100.00%


提示

#include <stdio.h>

#include <stdlib.h>

#include <string.h>

struct node

{

   char str[25];

   int cnt;

   struct node*l,*r;

};

int a;

struct node*creat(struct node*t,char s[])

{

    if(t==NULL)

    {

       t=(struct node*)malloc(sizeof(struct node));

       t->cnt=1;

       strcpy(t->str,s);

       t->l=NULL;

       t->r=NULL;

    }

    else

    {

        int cmp=strcmp(s,t->str);

        if(cmp>0)

        {

           t->r=creat(t->r,s);

        }

        else if(cmp<0)

        {

            t->l=creat(t->l,s);

        }

        else

            t->cnt++;

    }

  return t;

}

void inorder(struct node*t)//中序遍历从小到大依次输出

{

  if(t)

  {

      inorder(t->l);

      printf("%s %.2lf%c\n",t->str,t->cnt*100.0/a,'%');

      inorder(t->r);

  }

}

int main()

{

    int n,i;

    char st[25];

    struct node*t=NULL;

    scanf("%d\n",&n);

    a=n;

    while(n--)

    {

        gets(st);

        for(i=0;st[i];i++)

        {

            if('A'<=st[i]&&st[i]<='Z')

                st[i]+=32;

        }

        t=creat(t,st);

       

    }

    inorder(t);

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: