您的位置:首页 > 产品设计 > UI/UE

NanoApe Loves Sequence Ⅱ(尺取法)

2016-08-06 23:54 183 查看

题目链接:NanoApe Loves Sequence Ⅱ

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 339 Accepted Submission(s): 165


[align=left]Problem Description[/align]
NanoApe, the Retired Dog, has returned back to prepare for for the National Higher Education Entrance Examination!

In math class, NanoApe picked up sequences once again. He wrote down a sequence with n numbers and a number m on the paper.

Now he wants to know the number of continous subsequences of the sequence in such a manner that the k-th largest number in the subsequence is no less than m.

Note : The length of the subsequence must be no less than k.

[align=left]Input[/align]
The first line of the input contains an integer T, denoting the number of test cases.

In each test case, the first line of the input contains three integers n,m,k.

The second line of the input contains n integers A1,A2,...,An, denoting the elements of the sequence.

1≤T≤10, 2≤n≤200000, 1≤k≤n/2, 1≤m,Ai≤109

[align=left]Output[/align]
For each test case, print a line with one integer, denoting the answer.

[align=left]Sample Input[/align]

1
7 4 2
4 2 7 7 6 5 1

[align=left]Sample Output[/align]

18

题解:
前缀和真是个好东西。前缀和可以是前n个的和,前n项的最小值,前n项的最大值。。。
这个题用到前n项大于m的个数。然后用个尺取法。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn = 200005;
int a[maxn];
int prek[maxn];
int main()
{
int T;cin>>T;
while(T--)
{
int n,m,k;
cin>>n>>m>>k;
memset(prek,0,sizeof(prek));
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
if(a[i]>=m) prek[i] += prek[i-1]+1;
else prek[i] = prek[i-1];
}
long long ans = 0;
int sum = 0;
int t = 1;
for(int l=0;l<=n;l++)
{
while(t<=n&&sum<k)
{
sum = prek[t]-prek[l];
t++;
}
if(sum<k) break;
ans += (n-t+2);
sum = prek[t-1]-prek[l+1];
}
printf("%I64d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: