您的位置:首页 > 其它

POJ3267——The Cow Lexicon

2016-08-05 15:24 309 查看
The Cow Lexicon

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9558 Accepted: 4585
Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes
they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that
the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively: W and L

Line 2: L characters (followed by a newline, of course): the received message

Lines 3..W+2: The cows' dictionary, one word per line
Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.
Sample Input
6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output
2

Source

USACO 2007 February Silver
题目大意:

现有一个长度为L的字符串,已知W个单词,问最少删除多少个字母之后,字符串能变为单词的组合;

思路:

DP题;

用step[ i ]表示从str[ 0...i ]中最少去掉字符的个数, remove [ j, k ] 表示str[ j ... k ] 中包含了某个单词后去掉的字符个数。

状态转移方程就为 step[ i ] = min (step[i], d[ j - 1] + remove[ j, i ] ),0 < j <=i。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

int w, l;
char dir[610][310];
int len[610];
char str[310];
int step[310];

int dp()
{

step[0] = 1;
for( int i = 1;i < l;i++ )
{
step[i] = step[i-1]+1; //初始化为上一步删除的字母数+1
for( int j = 1;j <= w;j++ ) //从第一个单词开始遍历
{
int x = len[j] - 1, y = i;
if( x>y ) continue;
while( x>=0&&y>=0&&x<=y )
{
if( str[y]==dir[j][x] )
x--; //若匹配,单词的指针前移
y--; //无论匹不匹配 字符串的指针都前移
}
if( x<0 )
step[i] = min(step[i], step[y] + i - y - len[j]); //y可能为-1,因为step为全局数组,所以未操作的值都为0
}
}
return step[l-1];
}

int main()
{
cin>>w>>l;
cin>>str;
for( int i = 1;i <= w;i++ )
{
cin>>dir[i];
getchar();
len[i] = strlen(dir[i]);
}

cout<<dp()<<endl;

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj DP