您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表一:顺序建立链表

2016-08-05 13:13 211 查看


题目描述

输入N个整数,按照输入的顺序建立单链表存储,并遍历所建立的单链表,输出这些数据。


输入

第一行输入整数的个数N;

第二行依次输入每个整数。


输出

输出这组整数。


示例输入

8
12 56 4 6 55 15 33 62



示例输出

12 56 4 6 55 15 33 62



提示

不得使用数组!

简单的链表问题

源代码C<span style="font-size:14px;">#include <stdio.h>
#include <stdlib.h>
struct node{int data;struct node*next;};//定义结构体类型
struct node *create(int n)//建表
{
struct node *head,*tail,*p;
int i;
head=(struct node*)malloc(sizeof(struct node));
head->next=NULL;
tail=head;
for(i=0;i<n;i++)
{
p=(struct node*)malloc(sizeof(struct node));//插入元素
scanf("%d",&p->data);
p->next=NULL;
tail->next=p;
tail=p;
}
return (head);
};
void print(struct node *h)//打印表
{
struct node *p=h->next;
while(p!=NULL)
{
printf("%d ",p->data);
p=p->next;
}
}
int main()
{
int n;
scanf("%d",&n);
struct node *h;
h=create(n);
print(h);
return 0;
}</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息