您的位置:首页 > 其它

poj Flip game【DFS 枚举】

2016-08-03 17:23 357 查看
Flip Game

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 40227Accepted: 17464
Description
Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other
one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following
rules:

Choose any one of the 16 pieces.

Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).


Consider the following position as an example:

bwbw

wwww

bbwb

bwwb

Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw

bwww

wwwb

wwwb

The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input
The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
Output
Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the
goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).
Sample Input
bwwb
bbwb
bwwb
bwww

Sample Output
4


# include <stdio.h>
# include <string.h>
# define M 7

char s[5];
int map[M][M];

struct POS // 记录坐标位置
{
int x;
int y;
}p[100];
int count;

bool isok(); //判断棋盘是否为同一颜色
void flip(int cnt); //进行翻转
bool dfs(int n, int cnt); //深搜枚举

int main(void)
{
int i, j;
bool flag = false;
count = 0;
memset(map, 0, sizeof(map));
for (i = 1; i <= 4; i++)
{
scanf("%s", &s[1]);
for (j = 1; j <= 4; j++)
{
if (s[j] == 'w')
{
map[i][j] = 1;
}
else
{
map[i][j] = 0;
}

p[count].x = i;
p[count].y = j;
count ++;
}
}
for (i = 0; i < 16; i++)
{
if (dfs(i, 0))
{
flag = true;
break;
}
}
if (flag)
{
printf("%d\n", i);
}
else
{
printf("Impossible\n");
}
return 0;
}

bool dfs(int n, int cnt)
{
if (n == 0)
{
if (isok())
{
return true;
}
}
for (int k = cnt; k < 16; k++)
{
flip(k);
if (dfs(n-1, k+1))
{
return true;
}
flip(k);
}
return false;
}

void flip(int cnt)
{
map[p[cnt].x][p[cnt].y] = !map[p[cnt].x][p[cnt].y];
map[p[cnt].x - 1][p[cnt].y] = !map[p[cnt].x - 1][p[cnt].y];
map[p[cnt].x + 1][p[cnt].y] = !map[p[cnt].x + 1][p[cnt].y];
map[p[cnt].x][p[cnt].y - 1] = !map[p[cnt].x][p[cnt].y - 1];
map[p[cnt].x][p[cnt].y + 1] = !map[p[cnt].x][p[cnt].y + 1];
}

bool isok()
{
int t = map[1][1];
int cut = 0;
for (int i =1; i < 5; i++)
{
for (int j = 1; j < 5; j++)
{
if (map[i][j] == t)
{
cut ++;
}
}
}
if (cut == 16)
{
return true;
}
else
{
return false;
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  搜索 bfs poj