您的位置:首页 > 其它

poj 1125 Stockbroker Grapevine (最短路求最长距离)

2016-08-02 21:52 381 查看
Stockbroker Grapevine

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 33855 Accepted: 18707
Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours
in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass
the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community.
This duration is measured as the time needed for the last person to receive the information.
Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are,
and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring
to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of
stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 

It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the
message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.
Sample Input
3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output
3 2
3 10


这题每个人传递消息是同时进行的,求最后一个人知道消息的最短时间。

 先枚举每个人为起点的情况,然后这个情况下求每个人知道消息的最短时间,然后遍历一遍找到最大的那个,就是最后一个人收到消息的时间了。然后比较出所以情况中最后一个人知道消息的时间的最小值,即所求答案。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <cmath>
using namespace std;
int n;
int dis[10005];
int inf;
int a[1005][1005];
void djst(int s)
{
int i, j;
for(i=1; i<=n; i++)dis[i]=inf;
dis[s]=0;
int book[n+5];
for(i=1; i<=n; i++)
{
book[i]=0;
}
int v,mi=inf;
for(i=1; i<=n; i++)
{
mi=inf;
for(j=1; j<=n; j++)
{
if(dis[j]<mi && book[j]==0)
{
mi=dis[j];
v=j;
}
}
book[v]=1;
for(j=1; j<=n; j++)
{
if(book[j]==0)
{
if(dis[j]>dis[v]+a[v][j])
{
dis[j]=dis[v]+a[v][j];
}
}
}
}
return;
}
int main()
{
while(~ scanf("%d", &n))
{
if(n==0)break;
int i, j, m;
inf=99999999;
for(i=1; i<=n; i++)
{
for(j=1; j<=n; j++)
{
if(i<=j)
a[i][j]=a[j][i]= inf;
}
}
for(i=1; i<=n; i++)
{
scanf("%d" ,&m);
for(j=1; j<=m; j++)
{
int x, y;
scanf("%d%d", &x, &y);
a[i][x]=y;
}
}
int mi=inf, k=0;
for(i=1; i<=n; i++)
{
djst(i);
int ma=0;
for(j=1; j<=n; j++)
{
if(j!=i)
{
if(dis[j]>ma){ma=dis[j];}

}
}
if(ma<mi){mi=ma;k=i;}
}
if(k!=0)  printf("%d %d\n", k, mi);
else printf("disjoint\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: