您的位置:首页 > 产品设计 > UI/UE

UVA1584 UVALive3225 Circular Sequence【水题】

2016-07-30 23:50 183 查看
  Some DNA sequences exist in circular forms as inthe following figure, which shows a circular sequence“CGAGTCAGCT”, that is, the last symbol “T” in“CGAGTCAGCT” is connected to the first symbol “C”.
We alwaysread a circular sequence in the clockwise direction.


  Since it is not easy to store a circular sequence in a computeras it is, we decided to store it as a linear sequence.However, there can be many linear sequences that are obtainedfrom a circular sequence
by cutting any place of thecircular sequence. Hence, we also decided to store the linearsequence that is lexicographically smallest among all linearsequences that can be obtained from a circular sequence.






  Your task is to find the lexicographically smallest sequencefrom a given circular sequence. For the example in the figure,the lexicographically smallest sequence is “AGCTCGAGTC”. If there are two
or more linear sequences thatare lexicographically smallest, you are to find any one of them (in fact, they are the same).


Input

The input consists of T test cases. The number of test cases T is given on the first line of the inputfile. Each test case takes one line containing a circular sequence that is written as an arbitrary
linearsequence. Since the circular sequences are DNA sequences, only four symbols, ‘A’, ‘C’, ‘G’ and ‘T’, areallowed. Each sequence has length at least 2 and at most 100.


Output

Print exactly one line for each test case. The line is to contain the lexicographically smallest sequence for the test case.

Sample Input

2

CGAGTCAGCT

CTCC

Sample Output

AGCTCGAGTC

CCCT


Regionals 2004 >> Asia
- Seoul


问题链接UVA1584 UVALive3225 Circular Sequence

问题简述:(略)

问题分析

  这个问题是寻找循环串中的最小者。

  不移动字符串是关键,不然就会浪费时间。

程序说明

  程序中,封装了两个功能函数cirstrcmp()和cirstrprintf(),使得主程序的逻辑大为简化。这两个函数是通用性的函数,完全封装,与全局变量没有关系。

AC通过的C语言程序如下:

/* UVA1584 UVALive3225 Circular Sequence */

#include <stdio.h>
#include <string.h>

#define MAXN 100

/* 循环串比较,a[s]和a[t]开始的两个串进行比较,s>t,s=t,s<t返回值分别为负,0,正 */
int cirstrcmp(char a[], int s, int t, int length)
{
int count, i, j;

count = length;
for(i = s, j = t; count-- > 0; i = ++s % length, j = ++t % length) {
if(a[i] == a[j])
continue;
return a[i] - a[j];
}

return 0;
}

void cirstrprintf(char a[], int start, int length)
{
int count=0, i;

for(i = start; count++ < length; i = (i + 1) % length)
putchar(a[i]);
putchar('\n');
}

int main(void)
{
int t, min, len, i;
char s[MAXN+1];

scanf("%d", &t);
while(t--) {
scanf("%s", s);

len = strlen(s);

min = 0;
for(i=1; i<len; i++)
if(cirstrcmp(s, i, min, len) < 0)
min = i;

cirstrprintf(s, min, len);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: