您的位置:首页 > 其它

华为OJ 初级:输入一行字符,分别统计出包含英文字母、空格、数字和其它字符的个数

2016-07-30 15:50 363 查看
描述
输入一行字符,分别统计出包含英文字母、空格、数字和其它字符的个数。     /**
     * 统计出英文字母字符的个数。
     * 
     * @param str 需要输入的字符串
     * @return 英文字母的个数
     */
    public static int getEnglishCharCount(String str)
    {
        return 0;
    }
    
    /**
     * 统计出空格字符的个数。
     * 
     * @param str 需要输入的字符串
     * @return 空格的个数
     */
    public static int getBlankCharCount(String str)
    {
        return 0;
    }
    
    /**
     * 统计出数字字符的个数。
     * 
     * @param str 需要输入的字符串
     * @return 英文字母的个数
     */
    public static int getNumberCharCount(String str)
    {
        return 0;
    }
    
    /**
     * 统计出其它字符的个数。
     * 
     * @param str 需要输入的字符串
     * @return 英文字母的个数
     */
    public static int getOtherCharCount(String str)
    {
        return 0;
    }  
知识点字符串
运行时间限制10M
内存限制128
输入输入一行字符串,可以有空格
输出统计其中英文字符,空格字符,数字字符,其他字符的个数
样例输入1qazxsw23 edcvfr45tgbn hy67uj m,ki89ol.\\/;p0-=\\][
样例输出26 3 10 12
import java.util.Scanner;

public class Main{
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
String input = sc.nextLine();
sc.close();
int charNum = countChar(input);
int blankNum = countBlank(input);
int num = countNum(input);
int others = input.length() - charNum - num - blankNum;
System.out.println(charNum);
System.out.println(blankNum);
System.out.println(num);
System.out.println(others);
}

private static int countChar(String input) {
int count = 0;
for (int i = 0; i < input.length(); i++) {
if ((input.charAt(i) >= 'a' && input.charAt(i) <= 'z')
|| (input.charAt(i) >= 'A' && input.charAt(i) <= 'Z'))
count++;
}
return count;
}

private static int countBlank(String input) {
int count = 0;
for (int i = 0; i < input.length(); i++) {
if (input.charAt(i) == ' ')
count++;
}
return count;
}

private static int countNum(String input) {
int count = 0;
for (int i = 0; i < input.length(); i++) {
if ((input.charAt(i) >= '0') && (input.charAt(i) <= '9'))
count++;
}
return count;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐