您的位置:首页 > 产品设计 > UI/UE

HDU1242:Rescue(BFS+优先队列)

2016-07-29 21:07 260 查看

Rescue

Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

Sample Output

13

<pre name="code" class="cpp">#include<cstdio>
#include<queue>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 220;
char map[maxn][maxn];
int vis[maxn][maxn];
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
struct node
{
int x,y;
int time;
friend bool operator < (node a,node b)
{
return a.time>b.time;
}
};
int n,m;
int check(int x,int y)
{
if(x>=0&&x<n&&y>=0&&y<m&&map[x][y]!='#'&&!vis[x][y])
return 1;
else
return 0;
}
int bfs(int x,int y)
{
priority_queue<node>q;
while(!q.empty())
q.pop();
memset(vis,0,sizeof(vis));
node st,ed;
st.x=x;
st.y=y;
st.time=0;
vis[st.x][st.y]=1;
q.push(st);
while(!q.empty())
{
st=q.top();
if(map[st.x][st.y]=='a')
return st.time;
q.pop();
for(int i=0;i<4;i++)
{
ed.x=st.x+dir[i][0];
ed.y=st.y+dir[i][1];
if(check(ed.x,ed.y))
{
if(map[ed.x][ed.y]=='x')
ed.time=st.time+2;
else
ed.time=st.time+1;
vis[ed.x][ed.y]=1;
q.push(ed);
}
}
}
return 0;
}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
int i,j;
memset(map,0,sizeof(map));
int x,y,sum;
for(i=0;i<n;i++)
{
scanf("%s",map[i]);
for(j=0;j<m;j++)
{
if(map[i][j]=='r')
{
x=i;y=j;
break;
}
}
}
sum=bfs(x,y);
if(sum==0)
printf("Poor ANGEL has to stay in the prison all his life.\n");
else
printf("%d\n",sum);
}
return 0;
}


                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: