您的位置:首页 > 其它

poj 2251 Dungeon Master(BFS)

2016-07-29 19:11 531 查看
Dungeon Master

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 26549 Accepted: 10345
Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and
the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 

L is the number of levels making up the dungeon. 

R and C are the number of rows and columns making up the plan of each level. 

Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the
exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. 

If it is not possible to escape, print the line 
Trapped!

Sample Input
3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output
Escaped in 11 minute(s).
Trapped!

题意:
  本题的目的是问你从起点能否到达终点,如果能,则输出它能到达终点所需要的最短时间,这里可以直接用BFS进行收索


<pre name="code" class="cpp">#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
char map[40][40][40];
int vis[40][40][40];  // 定义一个vis数组表示判断该点是否已经遍历过
int dx[6] = {1,0,0,-1,0,0};
int dy[6] = {0,1,0,0,-1,0};
int dz[6] = {0,0,1,0,0,-1};
int l,r,c,i,j,k;
int sx,sy,sz,ex,ey,ez;
struct node{
int z;
int x;
int y;
int step;
};
void bfs(int x,int y,int z)
{
int falg = 0;
node now,next;
queue<node > q;  // 定义一个队列用于存放点
now.x = x;
now.y = y;
now.z = z;
now.step = 0; // 初始化步数为0
q.push(now);
while(!q.empty())
{
next = q.front();
q.pop();
if(next.x == ex && next.y == ey && next.z == ez)  // 如果找到终点,则跳出循环
{
falg = 1;
break;
}
for(i = 0 ; i < 6 ; i++) // 从6个方向开始收索
{
now.x = next.x + dx[i];
now.y = next.y + dy[i];
now.z = next.z + dz[i];
if(now.z >= 0 && now.z < l && now.x >= 0 && now.x < r && now.y >= 0 && now.y < c && map[now.x][now.y][now.z] != '#' && !vis[now.x][now.y][now.z])
{
vis[now.x][now.y][now.z] = 1;
now.step = next.step + 1;
q.push(now);
}
}
}
if(falg)
printf("Escaped in %d minute(s).\n",next.step);
else
printf("Trapped!\n");
}
int main()
{
while(scanf("%d%d%d",&l,&r,&c),(l + r + c))
{
memset(vis,0,sizeof(vis));
memset(map,'\0',sizeof(map));
for(i = 0 ; i < l ; i++)
for(j = 0 ; j < r ; j++)
for(k = 0 ; k < c ; k++)
{
cin >> map[j][k][i];
if(map[j][k][i] == 'S')   // 找到起点
{
sx = j;
sy = k;
sz = i;
}
if(map[j][k][i] == 'E')  // 找到终点
{
ex = j;
ey = k;
ez = i;
}
}
vis[sx][sy][sz] = 1;  // 起点已经遍历过了,所以要赋值为1
bfs(sx,sy,sz);
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: