您的位置:首页 > 产品设计 > UI/UE

Rescue

2016-07-29 18:19 337 查看
B - Rescue
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison. 

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up,
down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards. 

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.) 

 

Input

First line contains two integers stand for N and M. 

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file. 

 

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 

 

Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

 

Sample Output

13

#include<stdio.h>
#include<string.h>
#include<queue>
#include<iostream>
#include<algorithm>
using namespace std;
const int MAXN = 213;
int  vis[MAXN][MAXN];
char map[MAXN][MAXN];
int dis[4][2] = {0,1,1,0,0,-1,-1,0};

int m,n,ans,cnt,ax,ay,rx,ry;
struct node{
int x,y,time;
bool operator < (const node & a) const { return time > a.time; }
}e,ee;

priority_queue<node>q;

int bfs(int x,int y){

node e,ee;
e.x = x; e.y = y;e.time = 0;
q.push(e);

while(!q.empty() ){
e = q.top () ;q.pop() ;

for(int i=0; i<4; i++){
int nx = e.x + dis[i][0];
int ny = e.y + dis[i][1];
if(nx>=0 && ny>=0 && nx<n && ny<m && !vis[nx][ny] && map[nx][ny] != '#'){

if(map[nx][ny] == '.' || map[nx][ny] == 'a'){

ee.x = nx ; ee.y = ny ; ee.time = e.time + 1;
if (ee.x == ax && ee.y == ay) return ee.time;
q.push(ee);
vis[ee.x][ee.y] = 1;
}

if(map[nx][ny] == 'x'){

ee.x = nx ; ee.y = ny ; ee.time = e.time + 2;
q.push(ee);
vis[ee.x][ee.y] = 1;
}
}
}
}

return 0;

}

int main(){

while(scanf("%d %d", &n, &m) != EOF){

ans = 0;
ax = ay = rx = ry = 0;

for(int i=0; i<n; i++){
scanf("%s",&map[i]);
for(int j=0; j<m; j++){
if(map[i][j] == 'a'){	ax = i; ay = j;
}
if(map[i][j] == 'r'){	rx = i; ry = j;
}
}
}
memset(vis,0,sizeof(vis));
while(!q.empty() ) q.pop();
vis[rx][ry] = 1;
ans = bfs(rx,ry);
if(ans)
cout<<ans<<endl;
else
printf("Poor ANGEL has to stay in the prison all his life.\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: